Wrong Entity Framework provider type after upgrading to 8.17.1696?

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
raubv0gel
Posts: 14
Joined: Mon 27 Apr 2020 12:35

Wrong Entity Framework provider type after upgrading to 8.17.1696?

Post by raubv0gel » Thu 27 Aug 2020 22:07

After upgrading (with wizard) to dotConnect for MySQL 8.17.1696 I get the following Exception if I run the application (WPF, .NET Framework 4.8):

The Entity Framework provider type 'Devart.Data.MySql.Entity.MySqlEntityProviderServices, Devart.Data.MySql.Entity.EF6, Version=8.17.1666.0, Culture=neutral, PublicKeyToken=09af7300eec23701' registered in the application config file for the ADO.NET provider with invariant name 'Devart.Data.MySql' could not be loaded. Make sure that the assembly-qualified name is used and that the assembly is available to the running application. See http://go.microsoft.com/fwlink/?LinkId=260882 for more information.

App.config contians:

Code: Select all

	<entityFramework>
		<providers>
			<provider invariantName="Devart.Data.MySql"
			          type="Devart.Data.MySql.Entity.MySqlEntityProviderServices, Devart.Data.MySql.Entity.EF6, Version=8.17.1696.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
		</providers>
	</entityFramework>
References:
  • C:\Program Files (x86)\Common Files\Devart\dotConnect\NET2\Devart.Data.dll
  • C:\Program Files (x86)\Common Files\Devart\dotConnect\NET2\Devart.Data.MySql.dll
  • C:\Program Files (x86)\Devart\dotConnect\MySQL\Entity\EF6\Devart.Data.MySql.Entity.EF6.dll
Any idea what I’m doing wrong?

Best regards!

raubv0gel
Posts: 14
Joined: Mon 27 Apr 2020 12:35

Re: Wrong Entity Framework provider type after upgrading to 8.17.1696?

Post by raubv0gel » Fri 28 Aug 2020 09:19

It turns out that Visual Studio(?) did not rebuilded all *.config. I had to clear /bin and /obj. After build the correct configs are created by Visual Studio.

Shalex
Site Admin
Posts: 9307
Joined: Thu 14 Aug 2008 12:44

Re: Wrong Entity Framework provider type after upgrading to 8.17.1696?

Post by Shalex » Tue 01 Sep 2020 15:23

Thank you for letting us know that the issue is solved.

Post Reply