DevartEntityDeploy ERROR when building with latest version!

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
emp51302
Posts: 46
Joined: Fri 19 Aug 2011 20:57

DevartEntityDeploy ERROR when building with latest version!

Post by emp51302 » Thu 12 Jun 2014 18:12

I am getting the following error when building with a licensed copy of the latest version.

Code: Select all

The "DevartEntityDeploy" task could not be loaded from the assembly C:\Program Files (x86)\MSBuild\Devart\v3.5\Devart.Data.Entity.Build.Tasks.dll. Could not load file or assembly 'Microsoft.Build.Utilities, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified. Confirm that the <UsingTask> declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask. C:\Program Files (x86)\MSBuild\Devart\v3.5\Devart.Data.Entity.targets
Please advice!

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Re: DevartEntityDeploy ERROR when building with latest version!

Post by Shalex » Fri 13 Jun 2014 13:44

1. Make sure that the required assembly Devart.Data.Entity.Build.Tasks.dll is present in the C:\Program Files (x86)\MSBuild\Devart\v3.5\ folder.
2. If Devart.Data.Entity.Build.Tasks.dll is present in this location, create a test application, put Devart.Data.Entity.Build.Tasks.dll to its folder and try performing load assembly. If you get an Inner exception when doing this please send us its text.

emp51302
Posts: 46
Joined: Fri 19 Aug 2011 20:57

Re: DevartEntityDeploy ERROR when building with latest version!

Post by emp51302 » Fri 13 Jun 2014 14:19

Yes all is there. BUT;

I Installed Framework v2.0 and 3.5 and all went well. Which means that the current DevartEntityDeploy only works with framework v2.0??? Shouldn't it work with v4.0 and above?

It seems that there is a bug in the latest release too.

Please advise why do I have to install Framework v2.0 to compile my projects? I have all my projects runing under .NET Framework 4.5 but just to compile using the latest version of dotConnect for MySQL I had to install .NET Framework v2.0 also. Its just bizarre!

I have been using dotConnect for 3+ years now, but never encountered such an issue.

Any help would be appreciated.

Thank you,

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Re: DevartEntityDeploy ERROR when building with latest version!

Post by Shalex » Tue 17 Jun 2014 16:08

emp51302 wrote:Which means that the current DevartEntityDeploy only works with framework v2.0??? Shouldn't it work with v4.0 and above?
Thank you for your remark. We will correct our installation to take into account the case when .NET 2.0 or 3.5 are not installed on the target workstation. We will notify you when the issue is fixed.

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Re: DevartEntityDeploy ERROR when building with latest version!

Post by Shalex » Thu 10 Jul 2014 14:24

The bug with "DevartEntityDeploy" task, when .NET Framework 2.0 and .NET Framework 3.5 are not installed on the target workstation, is fixed in the new (8.3.201) build of dotConnect for MySQL.
It can be downloaded from http://www.devart.com/dotconnect/mysql/download.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?f=2&t=29947.

Post Reply