Windows 7 home Premium & dotConnect

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
Posts: 1
Joined: Tue 15 Mar 2011 14:26

Windows 7 home Premium & dotConnect

Post by digibility » Tue 15 Mar 2011 14:42

Hi Guys

Brainy and no so brainy people like me.

I was wondering if this has occurred with anyone else over the past 6 weeks.

We have a product that is still developed in framework 1.1, it work on all platforms without any hassles.

6 weeks ago, one oof our client desktop machines that acts as a mini-server running W7 Home Premium does not allow any MSQL connections.

It refuses to connect to localhost mysql server or even a remote internet mysql database.

Same application on any other machine works 100% and at this point yes, MOST of you are going "Firewall", sadly we have tried almost everything to get this sorted out.

The cannot connect to mysql error (10060) error appears on this machine.

We have uninstalled the AV and put AVG, disabled it even and added rules for the 3306 ports, we have re-installed the app several times, we have downloaded and installed the SP1 for win7, we have come to our whits end!

Any suggestions to see what the hassles is with the corelab.mysql.dll?

Coz with navicat we can connect to the localhost or the web mysql server.

How strange is that?

Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 16 Mar 2011 13:04

1. As I understood from your post, the application was working on the same workstation but suddenly (without any changes in application or at the workstation) it began to throw the 10060 error. Is this correct?
2. Please specify the exact text of the error. Is there any internal exception? Post here your stack trace.
3. Check your Windows Logs in the deployment environment: Computer > Properties > Manage > System Tools > Event Viewer > Windows Logs > the Application (and System) tabs. Is there any useful information to identify the reason of the problem?
4. Try using actual IP address in your connection string instead of localhost/
5. Specify the exact version ( of your CoreLab.MySql.dll and your connection string (roughly, without credentials).

Post Reply