Excpetion on Update

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
denkhe
Posts: 14
Joined: Mon 03 Jan 2011 15:33

Excpetion on Update

Post by denkhe » Mon 24 Jan 2011 14:15

I got the following table:

Code: Select all

CREATE TABLE IF NOT EXISTS SST_Probleme (
Id     INTEGER         PRIMARY KEY     AUTO_INCREMENT,
ProjektId     INTEGER         NOT NULL,
LfdNr         INTEGER         NOT NULL,
EFL           INTEGER         NOT NULL,
Beschreibung  VARCHAR(4000)   NULL,
Bemerkung     VARCHAR(4000)   NULL,
Erfasst       DATETIME        NOT NULL,
SETeam        VARCHAR(20 )    NULL,
Timestamp     TIMESTAMP DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP,
CONSTRAINT UNIQUE KEY keyProjektIdLfdNr (ProjektId,LfdNr),
CONSTRAINT UNIQUE KEY keyProjektIdEFL (ProjektId,EFL),
FOREIGN KEY(ProjektId) REFERENCES Anlaufmanagement.SST_Projekte(Id) ON DELETE CASCADE)
If i try to update a record the following SQL is executed in the database

Code: Select all

5 Query BEGIN
5 Query update anlaufmanagement.sst_probleme
   set SETeam = 'HAllo'
 where ((Id = 1) and (`Timestamp` = '2011-01-24 14:47:14'))
;select `Timestamp`
from anlaufmanagement.sst_probleme
where Id = p1
5 Query ROLLBACK 
The problem is the select with the invalid where clause. The field p1 does not exist.

SSDL:

Code: Select all


Any ideas?

Best regards
Heiko Denk

denkhe
Posts: 14
Joined: Mon 03 Jan 2011 15:33

Post by denkhe » Mon 24 Jan 2011 14:30

Update:

It is working, if I change the SSDL to

Code: Select all



AndreyR
Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Tue 25 Jan 2011 14:49

Could you please provide the code you were using for the update?
If possible, please send us (support * devart * com, subject "EF Computed Timestamp problem") a small test project reproducing the problem?

denkhe
Posts: 14
Joined: Mon 03 Jan 2011 15:33

Post by denkhe » Thu 27 Jan 2011 07:43

I sent the requested test-project to suppor@devart.com.

AndreyR
Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Fri 28 Jan 2011 10:36

Thank you for the project, I have reproduced the problem.
I will let you know about the results of our investigation.

denkhe
Posts: 14
Joined: Mon 03 Jan 2011 15:33

Post by denkhe » Wed 16 Feb 2011 08:36

Any news to this one?

AndreyR
Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Wed 16 Feb 2011 14:49

We have fixed the issue and in the process of testing at the moment.
The fix will be available in one of the nearest builds.
I will let you know as soon as it is available.

AndreyR
Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Thu 07 Apr 2011 11:50

We have released the new 6.10.135 build of dotConnect for MySQL. It fixes the issue.
The build can be downloaded from Download Page (trial version) or from Registered Users' Area (for users with valid subscription only).
For more information, please refer to this announcement.

Post Reply