Column with dollar character and dbForge

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
Bartman
Posts: 15
Joined: Sat 06 Jun 2009 19:22

Column with dollar character and dbForge

Post by Bartman » Sat 06 Jun 2009 21:21

Hi...
I've allready have asked a question about this issue while working with myDirect .net... This has been corrected into dotConnect for mySQL...

Thus, while implementing a VS 2005 Form using dbForge, and trying drag and drop on Server Explorer with one of my mySQL containing $ column tables, then I get this error (translated from french release) :

Code: Select all

Drag and drop has failed.
Error on SELECT clause : near expression of '$'.
FROM clause is missing.
Unable to analyze the request.
What should I do.
Thanks.

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Tue 09 Jun 2009 17:12

Please specify the versions of dotConnect for MySQL and dbForge Fusion for MySQL you are using.
You can find the versions at the Tools | MySQL (dbForge...) | About menu of Visual Studio.

Bartman
Posts: 15
Joined: Sat 06 Jun 2009 19:22

Rep : Column with dollar character and dbForge

Post by Bartman » Wed 10 Jun 2009 09:30

Shalex wrote:Please specify the versions of dotConnect for MySQL and dbForge Fusion for MySQL you are using.
You can find the versions at the Tools | MySQL (dbForge...) | About menu of Visual Studio.
I'm working on Vista SP2, running VS 2005 (version 8.0.50727.867), with .Net Framework 2.0.50727 SP2 (thus, .Net Framework 3.5 SP1 has been installed...)

dbForge Fusion for MySQL (trial) version is 3.10.227

PS : Both VS and dbForge are french releases.

Regards...

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 11 Jun 2009 12:57

We have reproduced the problem. We will investigate it and notify you about the results as soon as possible.

Bartman
Posts: 15
Joined: Sat 06 Jun 2009 19:22

Post by Bartman » Thu 11 Jun 2009 21:25

Shalex wrote:We have reproduced the problem. We will investigate it and notify you about the results as soon as possible.
Thanks for you efficiency...
Regards.

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 19 Jun 2009 10:02

We have fixed the problem for you. Look forward to the next build of dotConnect for MySQL that will be available in a week or two. I will post here when it is available for download.

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 15 Jul 2009 10:36

The new build of dotConnect for MySQL 5.40.37 is available for download now.
It can be downloaded from http://www.devart.com/dotconnect/mysql/download.html (trial version) or from Registered Users' Area (for users with valid subscription only).
For more information, please refer to http://www.devart.com/forums/viewtopic.php?t=15316 .

Bartman
Posts: 15
Joined: Sat 06 Jun 2009 19:22

New build - dollar issue

Post by Bartman » Mon 31 Aug 2009 11:38

Shalex wrote:The new build of dotConnect for MySQL 5.40.37 is available for download now.
It can be downloaded from http://www.devart.com/dotconnect/mysql/download.html (trial version) or from Registered Users' Area (for users with valid subscription only).
For more information, please refer to http://www.devart.com/forums/viewtopic.php?t=15316 .
Back from vacation, I've download the new build of dotConnect (5.4.39) and dbForge 2.10 to test new features (correction of dollar column named...).

Unfortunately, it says "trial period expired".

How do I bypass this ?

Thanks.

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 02 Sep 2009 15:05

Bartman, we have answered you by e-mail.

Bartman
Posts: 15
Joined: Sat 06 Jun 2009 19:22

Post by Bartman » Thu 03 Sep 2009 14:38

Shalex wrote:Bartman, we have answered you by e-mail.
Thanks ! It works... again :-)
We surely soon will purshase a fully release of this product.

Regards.

Post Reply