SQL Server Reporting Services - dotConnect not available

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
davidh
Posts: 6
Joined: Mon 30 Mar 2009 15:04

SQL Server Reporting Services - dotConnect not available

Post by davidh » Wed 20 May 2009 16:11

When I use SSRS I can't find the dotConnect for MySQL option available for my "shared data source".

Is SSRS in Microsoft visual studio 2005 not supported?

I am currently using the trial copy of dotConnect as I'm waiting for the purchase order to get back to me (it's with the head of department).

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 21 May 2009 10:11

We cannot reproduce the problem with SSRS 2005 (Report Server Project). I have sent you the screenshot of the Type drop-down list of the Shared Data Source menu on my machine. Do you have the same? Please specify the version of your dotConnect for MySQL (the Tools | MySQL | About menu of Visual Studio). Please give us a more detailed description of the problem.

davidh
Posts: 6
Joined: Mon 30 Mar 2009 15:04

Post by davidh » Thu 21 May 2009 10:42

I don't get any entries for Devart in the 'Type' drop down (unlike the screen shot you sent me).

my dotConnect is: 5.20.29.0

I had a previous issue of Devart.Data.MySql.xsl cartridges not being available for SSAS projects. Could this be the same issue? Where should these cartridges be located for the SSRS projects/software?

I'm using
OS: Windows XP
Visual studio: 8.0.50727.42
SQL server: 2005

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 21 May 2009 14:08

dotConnect for MySQL installation package performs the following actions to make the SSRS support be available:

1) places Devart assemblies at
a) \Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\Devart.Data.MySql.ReportingServices.dll
b) \Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\Devart.Data.MySql.ReportingServices.Design.dll
c) \Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\bin\Devart.Data.MySql.ReportingServices.dll
d) Devart.Data.MySql.ReportingServices.dll (GAC, version 5.20.29.0)
e) Devart.Data.MySql.ReportingServices.dll (GAC, version 5.20.29.1)

2) makes the records with the Devart.Data.MySQL entry to the following files:
a) \Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\RSPreviewPolicy.config
b) \Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\RSReportDesigner.config
c) \Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\rsreportserver.config
d) \Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\rssrvpolicy.config

davidh
Posts: 6
Joined: Mon 30 Mar 2009 15:04

Post by davidh » Thu 21 May 2009 15:20

1) All those files appear to be there without issue.

2) I can't find any reference to devart in any of the .config files. I'm assuming this is where the issue lies.

Can you tell me the strings to copy into each of the files (and where they go).

Thanks in advance :)

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 22 May 2009 15:15

Here are the entries from the mentioned files. Please change the paths and assemblies versions to your own.
1) \Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\RSPreviewPolicy.config

Code: Select all

<configuration>
  <mscorlib>
    <security>
      <policy>
        <PolicyLevel version="1">
          <CodeGroup class="UnionCodeGroup" version="1" PermissionSetName="FullTrust" Name="Devart.Data.MySql" Description="Code group for Devart.Data.MySql.ReportingServices data processing extension">
            <IMembershipCondition class="UrlMembershipCondition" version="1" Url="D:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\Devart.Data.MySql.ReportingServices.dll" />
          </CodeGroup>
        </PolicyLevel>
      </policy>
    </security>
  </mscorlib>
</configuration>
2) \Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\RSReportDesigner.config

Code: Select all

<Configuration>
  <Extensions>
    <Data>
      <Extension Name="Devart.Data.MySql" Type="Devart.Data.MySql.ReportingServices.MySqlConnectionWrapper, Devart.Data.MySql.ReportingServices, Version=5.20.29.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </Data>
    <Designer>
      <Extension Name="Devart.Data.MySql" Type="Devart.Data.MySql.ReportingServices.Design.MySqlQueryDesigner, Devart.Data.MySql.ReportingServices.Design, Version=5.20.29.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </Designer>
  </Extensions>
</Configuration>
3) \Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\rsreportserver.config

Code: Select all

<Configuration>
  <Extensions>
    <Data>
      <Extension Name="Devart.Data.MySql" Type="Devart.Data.MySql.ReportingServices.MySqlConnectionWrapper, Devart.Data.MySql.ReportingServices, Version=5.20.29.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </Data>
  </Extensions>
</Configuration>
4) \Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\rssrvpolicy.config

Code: Select all

<configuration>
  <mscorlib>
    <security>
      <policy>
        <PolicyLevel version="1">
          <CodeGroup class="UnionCodeGroup" version="1" PermissionSetName="FullTrust" Name="Devart.Data.MySql" Description="Code group for Devart.Data.MySql data processing extension">
            <IMembershipCondition class="UrlMembershipCondition" version="1" Url="d:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\bin\Devart.Data.MySql.ReportingServices.dll" />
          </CodeGroup>
        </PolicyLevel>
      </policy>
    </security>
  </mscorlib>
</configuration>

davidh
Posts: 6
Joined: Mon 30 Mar 2009 15:04

Post by davidh » Tue 26 May 2009 09:17

I have made those changes and have been able to connect and create reports based from the MySQL database.

However I had to copy the connection string from another project as the button for generating the connection string was disabled in SSRS.

Also I can't seem to get parameters to work properly, either using :param or @param seems to fail at the "Preview" tab.

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 27 May 2009 10:44

We will investigate the issue and notify you about the results as soon as possible.

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 24 Sep 2009 13:52

1. There is no technical possibility to overcome the problem with the connection string generation.
2. We have supported the native parameters for MySQL (:param1).

Post Reply