Trial doesn't work at all

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
rsteckly
Posts: 1
Joined: Mon 12 Jan 2009 22:09

Trial doesn't work at all

Post by rsteckly » Mon 12 Jan 2009 22:11

Hi,

The trial for dotconnect Professional doesn't work at all.

After installing, whenever I try connecting it says that the license is invalid.

I've tried going to MySQL menu and importing the license information for an ASP.NET. It just says there are problems with the installation and that it doesn't work.

I'm about to give up on it, honestly. Why can't you download something with a working trial license?

Ron

RobertM
Posts: 5
Joined: Mon 12 Jan 2009 22:33

Post by RobertM » Mon 12 Jan 2009 22:37

I am also having the same problem.

Heres My information "dotConnect for MySQL is installed not correctly." is listed under Tools->MySql->License Information.

I have uninstalled/reinstalled several times with no luck.

Vista 64bit with 2008 Professional SP1.

Thanks,
Robert

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Tue 13 Jan 2009 09:09

Rsteckly, please check the version of dotConnect for MySQL you are using (Visual Studio, Tools | MySQL | About dotConnect for MySQL). Is it 5.0.16.0? Tell us also about your environment (OS and IDE).

RobertM, what is the version of dotConnect for MySQL you have? Is its edition Professional Trial too?

RobertM
Posts: 5
Joined: Mon 12 Jan 2009 22:33

Post by RobertM » Tue 13 Jan 2009 13:31

My dotConnect for MySql is Version: 5.0.16.0 Professional Trial.
Thanks,
Robert

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Tue 13 Jan 2009 14:13

Thank you for the bug report. The problem is fixed. Look forward to the next build of dotConnect for MySQL that will be available in several days. I will notify you when it is released.

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 15 Jan 2009 15:04

The new build (5.00.20) of dotConnect for MySQL is available now.
It can be downloaded from http://www.devart.com/dotconnect/mysql/download.html (trial version) or from Registered Users Area (for users with valid subscription only).

For more information, please visit: http://www.devart.com/forums/viewtopic.php?t=13899

RobertM
Posts: 5
Joined: Mon 12 Jan 2009 22:33

Post by RobertM » Fri 16 Jan 2009 05:16

Still doesn't work, same error. After the uninstall I searched my pc for Devart and removed all Devart related reg keys. Version from the Visual Studio menu is 5.0.20.0.
Thanks,
Robert

Paul
Posts: 725
Joined: Thu 28 Oct 2004 14:06

Post by Paul » Fri 16 Jan 2009 11:54

Try removing "bin" and "obj" folders from you application and recompiling it again. If you still have this problem please send us compiled executable file (*.exe) of a small test project.
What is exact text of the error message that you have in run time of the test project?

RobertM
Posts: 5
Joined: Mon 12 Jan 2009 22:33

Post by RobertM » Fri 16 Jan 2009 16:00

Im not even trying it in a project yet, I am just trying to add a connection to my Server explorer using dotConnect. If my IDE can't connect to let me browse my database then trial is to limited to see if I would even buy the product or the trial doesn't work.
Thanks,
RobertM

RobertM
Posts: 5
Joined: Mon 12 Jan 2009 22:33

Post by RobertM » Fri 16 Jan 2009 20:41

Double checked and tryed to create a simple demo app. After creating a demo app (Just adding the referance and the licenses.lix) the following error is listed in the "License Information" "Error in the compiled module: License not valid due to the problems with dotConnect for MySQL installation."
Thanks,
Robert

Shalex
Site Admin
Posts: 8239
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Mon 19 Jan 2009 10:20

Please send me (alexsh at devart.com) compiled executable file (*.exe) of a small test project where the MySqlConnection object is created, and where the Open() method is invoked. It will allow us to investigate the problem in detail.

Post Reply