Connection string not resolved in latest version

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
jammerjam
Posts: 27
Joined: Wed 09 Jan 2008 22:56

Connection string not resolved in latest version

Post by jammerjam » Fri 26 Sep 2008 21:34

I downloaded the latest version and opened up my DataSet.xsd file which references a connection string I have in the connections.config file.

However, when I go to edit an existing Table Adapter, I get this error:

Code: Select all

Configure TableAdapter mydata failed.

Unable to find connection 'mydata' for object 'Web.config'.  The connection string could not be found in application settings, or the data provider associated with the connection string could not be loaded
I can easily add this entry in the web.config, but it already exists in the machine.config file. The site itself works fine, but I need to modify the data level and add some new parameters.

Shalex
Devart Team
Posts: 8080
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 01 Oct 2008 14:36

Please try setting the "Specific Version = false" property of the CoreLab.MySql assembly in References of your project. And notify us about results. Does the problem persist?

jammerjam
Posts: 27
Joined: Wed 09 Jan 2008 22:56

No help

Post by jammerjam » Wed 01 Oct 2008 14:46

That didn't help - I get the same error.

Here's my current entry in the machine connections.config file:

Code: Select all



Shalex
Devart Team
Posts: 8080
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 03 Oct 2008 08:36

Please follow these steps:
  • Remove "Specific Version=false" from the definition of connectionString. The "Specific Version=false" property should be set in the Properties windows of the references to the CoreLab.Data, CoreLab.MySql, CoreLab.MySql.Web assemblies. You can get to the Property window of the references in this way: right click on your web project, choose Properties | References tab. Select every reference of 3 mentioned and press F4 - as a result, the Properties window will appear. Set the "Specific Version=false" property here.
  • Open your Web.config file of the project. Take a look at the tag and change the Version attribute of every Core Lab assembly to the currently installed version. The current version of MyDirect .NET you can find here: Tools | MySQL | About MyDirect .NET...
If the problem persists, let us know.

jammerjam
Posts: 27
Joined: Wed 09 Jan 2008 22:56

Post by jammerjam » Fri 03 Oct 2008 12:52

1. I don't have that option in VS 2008. And if I look at the properties when choosing the dll in the Solution Explorer I only have 3 properties I can even view:

Code: Select all

Auto-refresh Path
File Name
Full Path
2. I don't have any references to any of the 3 dlls in my web.config.

Shalex
Devart Team
Posts: 8080
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Tue 07 Oct 2008 11:48

We have sent you a letter with screenshots that show how to set the "Specific version=false" for Core Lab assemblies.

Post Reply