EntityDeveloper not working

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for MySQL
Post Reply
sanvenk
Posts: 2
Joined: Mon 25 Oct 2021 08:40

EntityDeveloper not working

Post by sanvenk » Mon 25 Oct 2021 08:45

the following error occurs when the model is opened and when I try to compile

The provider did not return a ProviderManifest instance. Attempt by security transparent method 'Devart.Data.MySql.MySqlUtils.h(System.String)' to access security critical method 'Devart.Common.Utils.TryParseInt(System.String, Int32 ByRef)' failed.

Assembly 'Devart.Data.MySql.Entity.EF5, Version=8.19.2001.0, Culture=neutral, PublicKeyToken=09af7300eec23701' is marked with the AllowPartiallyTrustedCallersAttribute, and uses the level 2 security transparency model. Level 2 transparency causes all methods in AllowPartiallyTrustedCallers assemblies to become security transparent by default, which may be the cause of this exception.

please help to resolve this issue.

Shalex
Site Admin
Posts: 9424
Joined: Thu 14 Aug 2008 12:44

Re: EntityDeveloper not working

Post by Shalex » Tue 26 Oct 2021 15:35

Thank you for your report. We have reproduced the issue and are investigating it. As soon as we have any results, we will contact you.

sanvenk
Posts: 2
Joined: Mon 25 Oct 2021 08:40

Re: EntityDeveloper not working

Post by sanvenk » Fri 05 Nov 2021 11:04

Any updates/progress on this issue? I am still facing this issue with build 8.19.2001. I am using windows 11

Shalex
Site Admin
Posts: 9424
Joined: Thu 14 Aug 2008 12:44

Re: EntityDeveloper not working

Post by Shalex » Tue 09 Nov 2021 16:58

The investigation is in progress. We will notify you about the fix.

Post Reply