Error with memos

Discussion of open issues, suggestions and bugs regarding usage of dbExpress drivers for MySQL in Delphi and C++Builder
Post Reply

Error with memos

Post by joncmora » Wed 19 Jan 2005 03:05

I've tried 2.10 trial and found this bug. It seems that the driver doesn't handle memos correctly if the first character of the memo is byte 0. Borland's MySQL DBX driver handles this correctly.

My field is of type TEXT. My queries look like this:

insert into mytable (myfield) values (:myfield)
update mytable set myfield = :myfield

Delphi interpreted the parameter as ftMemo. In Delphi, my code looks like this:

SQLDataSet1.Params[0].AsMemo := #0#224#7#1#200#42#227#115#92;

After execution, looking at the length of the stored value reveals 0 chars:

select length(cast(myfield as char)) from mytable

The memo is a fingerprint feature supplied by a fingerprint scanner.

Posts: 1693
Joined: Thu 28 Oct 2004 13:56

Re: Error with memos

Post by Ikar » Thu 20 Jan 2005 08:39

Thank you for information.
We reproduced your problem and fixed it. This fix will be included in the next DbxSda build.

Post Reply