'LIMIT 0,i' does not work with 'ORDER BY'

Discussion of open issues, suggestions and bugs regarding usage of dbExpress drivers for MySQL in Delphi and C++Builder
Post Reply
Posts: 1
Joined: Tue 16 May 2006 19:53

'LIMIT 0,i' does not work with 'ORDER BY'

Post by kolekrille » Tue 16 May 2006 20:10

The following query raises a stupid 'list index out of bounds' error:
when the lower limit is 0 and order by is included (can be solved by just including the upper limit, but it is still a bug, right?).

Anyway it took me 2 hours to track it down, so it would be great if someone fixed it to save time for people who have funnier things to do with their time.

Posts: 2098
Joined: Tue 14 Feb 2006 10:14

Post by Antaeus » Wed 17 May 2006 07:27

Unfortunately we couldn't reproduce the problem.
Please send us (EvgeniyD*crlab*com) a complete small sample to demonstrate it, including script to create and fill table.
Also supply us following information
- Exact version of Delphi, C++ Builder or Kylix
- Exact version of MyDAC. You can see it in About sheet of TMyConnection Editor
- Exact version of MySQL server and MySQL client. You can see it in Info sheet of TMyConnection Editor

Post Reply