Application no longer works on 64-bit machine

Discussion of open issues, suggestions and bugs regarding usage of dbExpress drivers for MySQL in Delphi and C++Builder
Post Reply
Marlon
Posts: 2
Joined: Thu 06 Aug 2009 12:42
Location: Belgium

Application no longer works on 64-bit machine

Post by Marlon » Thu 06 Aug 2009 13:09

Hi everybody,

We have developed an application using dbExpress driver for MySQL.

Until recently, everything went fine, but ever since we started testing on 64-bit platforms (Windows 2008 Server), the application no longer works.

Through a dependency monitor, I was able to see that an access violation occurs inside the dbexpmda.dll file.

Has anyone had any similar experiences with dbExpress?

I could not find any on the website, but is there a specific version of dbExpress for 64-bit platforms? Is there a specific dbexpmda.dll file perhaps? Are we doing something wrong, or is this a known bug?

Thanks,

Marlon

Dimon
Devart Team
Posts: 2885
Joined: Mon 05 Mar 2007 16:32

Post by Dimon » Fri 07 Aug 2009 07:42

To solve this problem try to use the Direct mode to connect to MySQL database.
For this you should set the TSQLConnection.ConnectionName property to 'Devart MySQL Direct' value or the TSQLConnection.DriverName property to 'DevartMySQLDirect' and the TSQLConnection.GetDriverFunc property to 'getSQLDriverMySQLDirect' value.

Marlon
Posts: 2
Joined: Thu 06 Aug 2009 12:42
Location: Belgium

Post by Marlon » Mon 10 Aug 2009 09:35

Hi Dimon,

Thank you for your suggestion!

However, I'm afraid I have to report that it didn't work - I've tried changing the properti's you mentioned, but our application still crashes.

As soon as we try to export data to the database, the application crashes. Through a monitoring tool, I can see that the dbexpmda.dll is causing an access violation.

Does anyone have any suggestions as to what we can try next?

Thanks in advance,

Marlon

Dimon
Devart Team
Posts: 2885
Joined: Mon 05 Mar 2007 16:32

Post by Dimon » Mon 10 Aug 2009 11:47

We have answered you by e-mail.

dannypb
Posts: 8
Joined: Thu 27 Aug 2009 15:40
Location: Delaware, USA

Post by dannypb » Mon 31 Aug 2009 13:50

I wish you had answered him here. I am having the same problem.

Dimon
Devart Team
Posts: 2885
Joined: Mon 05 Mar 2007 16:32

Post by Dimon » Mon 31 Aug 2009 14:54

We have reproduced this problem and fixed it. This fix will be included in the next DbxMda build.

Post Reply