dbexpress 6.11.15 compatibility with mysql 8.0.15

Discussion of open issues, suggestions and bugs regarding usage of dbExpress drivers for MySQL in Delphi and C++Builder
Post Reply
fred65
Posts: 2
Joined: Thu 09 May 2019 16:04

dbexpress 6.11.15 compatibility with mysql 8.0.15

Post by fred65 » Thu 09 May 2019 16:16

Hello,
I am trying to use the latest version of dbexpress driver (6.11.15), with MySQL 8.0.15.
But I have the following error message when attempting to connect to the database:
"client does not support authentication protocol requested by server; consider upgrading MySQL client."
Previously, with dbexpress 6.9 and MySQL 6.3.9, I did not have this problem.
Is the latest version of dbexpress compatible with MySQL 8.0.15?

ViktorV
Devart Team
Posts: 2780
Joined: Wed 30 Jul 2014 07:16

Re: dbexpress 6.11.15 compatibility with mysql 8.0.15

Post by ViktorV » Fri 10 May 2019 06:51

dbExpress driver for MySQL is compatible with MySQL 8.0.15
Please make sure you are using Direct Mode. For this, set the TSQLConnection.DriverName property to DevartMySQLDirect.
Please check whether the problem is reproduced on our Query demo project. You can find the demo project in the You can find the demo project in the %DBXMySQLDemos%\Win32\Query directory, where %DBXMySQLDemos% is the dbExpress driver for MySQL Demo projects installation path on your computer.
If the issue is reproduced on our Query demo project, to investigate the issue, please allow test access to your server and, if possible, send to us using contact form https://devart.com/company/contactform.html the necessary connection data.

fred65
Posts: 2
Joined: Thu 09 May 2019 16:04

Re: dbexpress 6.11.15 compatibility with mysql 8.0.15

Post by fred65 » Fri 10 May 2019 08:49

Yes, it works with the demo program.
It's curious though, with a previous version of MySQL and the Devart library, it worked in my program ... But not more with the new versions.
So I searched in the code of my program, and changed the settings to put the same as in the demo program.
It works now.
Thanks for your intervention.

ViktorV
Devart Team
Posts: 2780
Joined: Wed 30 Jul 2014 07:16

Re: dbexpress 6.11.15 compatibility with mysql 8.0.15

Post by ViktorV » Fri 10 May 2019 08:51

Thank you for the interest to our product.
It is good to see that the problem has been solved.
If you have any questions during using our products, please don't hesitate to contact us - and we will try to help you solve them.

Post Reply