OracleDataReader fetches first 6 columns only

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 2
Joined: Mon 11 Apr 2005 11:18
Location: Russian Federation

OracleDataReader fetches first 6 columns only

Post by Byte » Mon 11 Apr 2005 11:48

I've created OracleCommand with select * from MY_VIEW as CommandText. The type of a command is "Text".

When I try to execute this command, storing the result in a OracleDataReader (OracleCommand->ExecuteReader), I have a trouble with reader's columns. When I refer to the first 6 columns of a result set, I see what I want. But, reading the values of others columns of any row in a reader gets the null result.

Is it because of using a trial version of component?



Post by Guest » Tue 12 Apr 2005 09:44

More concrete, the problem is in a result set of the OracleCommand. I use OracleCommand object as the SelectCommand in OracleDataAdapter, and the result is the same. Please, HELP!!

Devart Team
Posts: 264
Joined: Thu 28 Oct 2004 13:56

Post by Oleg » Tue 12 Apr 2005 14:09

This is trial limitation.
OraDirect .NET trial version returns record sets with maximum 6 columns.

Posts: 1
Joined: Wed 08 Jun 2005 14:10

Post by Alex30 » Wed 08 Jun 2005 14:14

I have the same exact problem.

But I had trial version installed on the server. Then I tried to install the professional version. But it told me that I had to uninstall the previous version. However, During the uninstall process, I would always get error, and it would not go through.

So I just removed the directory and all the registry settings that I could find. Then I have installed the Proffessional version, but I still get only 6 records.

Can some one help me?


Posts: 725
Joined: Thu 28 Oct 2004 14:06

Post by Paul » Thu 09 Jun 2005 12:39

Try to find another copy of CoreLab.Oracle.dll on your compute. Check in debugger which copy of CoreLab.Oracle.dll is loaded in your application.

Post Reply