Cannot install package for EF6

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply

Do you use .NET Core or .NET Framework?

All my projects are .NET Core 3 or later
0
No votes
All my projects are .NET Framework 4.x
1
100%
I have a mix of .NET Core and .NET Framework projects
0
No votes
 
Total votes: 1

glittle
Posts: 5
Joined: Thu 14 Nov 2019 17:51

Cannot install package for EF6

Post by glittle » Thu 14 Nov 2019 18:36

In Visual Studio 2019, I created a simple console app targeting .NET Framework 4.8.

Using package manager, I installed "EntityFramework" (version 6.3.0) and "Devart.Data.Oracle" (version 9.9.872).

However, when trying to install "Devart.Data.Oracle.EF6", I get an error:
"Could not install package 'Devart.Data.Oracle.EF6 9.9.872'. You are trying to install this package into a project that targets '.NETFramework,Version=v4.8', but the package does not contain any assembly references or content files that are compatible with that framework."
Is there any good reason why the EF6 package will only support .NET Standard 2.1? That eliminates all .NET Framework code!

As a library, you should target the lowest .NET Standard that you can!

In nuGet, you have "Devart.Data.Oracle.EF6" and "Devart.Data.Oracle.EFCore". But the EF6 version is effectively unusable since no one using EF6 can actually use that package!

Changing existing systems from .NET Framework to .NET Core, just to be able to use the EF6 package. is not a viable option.
Last edited by glittle on Thu 14 Nov 2019 19:07, edited 1 time in total.

glittle
Posts: 5
Joined: Thu 14 Nov 2019 17:51

Re: Cannot install package for EF6

Post by glittle » Thu 14 Nov 2019 19:05

If you want to keep .NET Standard 2.1 as the target, could you at least also produce a version that targets .NET Standard 2.0?

Shalex
Site Admin
Posts: 9023
Joined: Thu 14 Aug 2008 12:44

Re: Cannot install package for EF6

Post by Shalex » Fri 15 Nov 2019 14:43

1. With .NET Framework 4.8, please use assemblies shipped with the provider installation: "C:\Program Files (x86)\Devart\dotConnect\Oracle\".

2. EF 6.3 is supported by .NET Standard starting from v2.1.

glittle
Posts: 5
Joined: Thu 14 Nov 2019 17:51

Re: Cannot install package for EF6

Post by glittle » Fri 15 Nov 2019 18:06

EF 6.3 is supported by .NET Standard starting from v2.1
However, .NET Framework 4.x does not support v2.1, so no .NET Framework application can use it.

Again, as a library, you should aim as low as you can. If you could support .NET Standard 2.0, then all .NET Framework 4.8 applications could use it.

Shalex
Site Admin
Posts: 9023
Joined: Thu 14 Aug 2008 12:44

Re: Cannot install package for EF6

Post by Shalex » Mon 18 Nov 2019 11:54

The current implementation of dotConnect for Oracle includes two sets of assemblies:

1) the .NET Framework Devart.* assemblies which are shipped with installation:
* assemblies are created in C:\Program Files (x86)\Devart\dotConnect\Oracle\ , GAC 2.0 (C:\Windows\assembly\GAC_MSIL\), GAC 4.0 (C:\Windows\Microsoft.NET\assembly\GAC_MSIL\)
* licensing approach is described at https://www.devart.com/dotconnect/oracl ... nsing.html

2) the .NET Standard (.NET Core) Devart.* assemblies which are available via NuGet:
* you can download packages from https://www.nuget.org/packages/devart.data.oracle.ef6
* licensing approach is described at https://www.devart.com/dotconnect/oracl ... ndard.html
Again, as a library, you should aim as low as you can. If you could support .NET Standard 2.0, then all .NET Framework 4.8 applications could use it.
.NET Standard 2.1 is the only .NET Standard version with EF 6.3 support (https://www.nuget.org/packages/EntityFramework/6.3.0 > the Dependencies section).
We do not have a technical possibility to support EF 6.3 in .NET Standard 2.0 assemblies, because .NET Standard 2.0 itself doesn't include EF 6.3 implementation.

The .NET Framework Devart.* assemblies are currently not available via NuGet.

glittle
Posts: 5
Joined: Thu 14 Nov 2019 17:51

Re: Cannot install package for EF6

Post by glittle » Fri 13 Dec 2019 03:35

Here's a paragraph from the Entity Framework Core 3.1 announcement:
EF Core 3.1 reintroduces support for .NET Standard 2.0, rather than requiring .NET Standard 2.1 as was the case for EF Core 3.0. This means EF Core 3.1 will run on .NET Framework versions that support the standard.
Please consider supporting .NET Standard 2.0 for DevArt libraries too!

Shalex
Site Admin
Posts: 9023
Joined: Thu 14 Aug 2008 12:44

Re: Cannot install package for EF6

Post by Shalex » Fri 13 Dec 2019 18:30

https://www.nuget.org/packages/Microsof ... Core/3.1.0 depends on .NET Standard 2.0. We will notify you when EF Core 3.1 is supported by dotConnect for Oracle.

https://www.nuget.org/packages/EntityFramework/6.4.0 works with .NET Standard 2.1 only. Refer to the Dependencies section of the package.

Shalex
Site Admin
Posts: 9023
Joined: Thu 14 Aug 2008 12:44

Re: Cannot install package for EF6

Post by Shalex » Tue 24 Dec 2019 17:40

Entity Framework Core 3.1 is supported: viewtopic.php?f=1&t=39716.

Post Reply