Upgrading from v5

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
MisinformedDNA
Posts: 1
Joined: Thu 03 Aug 2017 23:51

Upgrading from v5

Post by MisinformedDNA » Fri 04 Aug 2017 13:50

I need to move an existing on-premise app to Azure. The app uses an ASP.NET Web Site (not Web App), that uses Dynamic Data (https://msdn.microsoft.com/en-us/librar ... .100).aspx). It also uses dotConnect for Oracle 5.70.152.0 and runs fine on-premise. When I try to run the code locally, as may be expected, I get the "License not found" error.

I am a beginner at Oracle and dotConnect and tried to upgrade to the latest dotConnect (with a trial license), but I keep getting the error: "Failed to find or load the registered .Net Framework Data Provider."

Can you please provide steps for me to upgrade and get this app running successfully?

I've included my web.config:

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<configuration>
	<connectionStrings>
  <add name="App_Code.OBIEEAdminConnectionString"
  	connectionString="metadata=~/App_Code/OBIEEAdmin.csdl|~/App_Code/OBIEEAdmin.ssdl|~/App_Code/OBIEEAdmin.msl;provider=Devart.Data.Oracle;provider connection string="User Id=XXXX;Password=XXXX;Server=XXXX;Home=XXXX;Persist Security Info=True""
  	providerName="System.Data.EntityClient"/>
 </connectionStrings>
	<system.web>
		<compilation debug="true" targetFramework="4.0">
			<assemblies>
				<add assembly="System.Web.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
				<add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
				<add assembly="Devart.Data.Oracle, Version=5.70.152.0, Culture=neutral, PublicKeyToken=09AF7300EEC23701"/></assemblies>
		</compilation>
    <customErrors mode="Off" defaultRedirect="Error.aspx">
    </customErrors>
	</system.web>
	<system.webServer>
		<modules runAllManagedModulesForAllRequests="true"/>
	</system.webServer>
	<system.data>
		<DbProviderFactories>
			<remove invariant="Devart.Data.Oracle"/>
			<add name="dotConnect for Oracle" invariant="Devart.Data.Oracle" description="Devart dotConnect for Oracle"
				type="Devart.Data.Oracle.OracleProviderFactory, Devart.Data.Oracle,&#xA;       Version=5.70.152, Culture=neutral, PublicKeyToken=09af7300eec23701"/>
		</DbProviderFactories>
	</system.data>
</configuration>

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Re: Upgrading from v5

Post by Shalex » Wed 09 Aug 2017 14:00

MisinformedDNA wrote:tried to upgrade to the latest dotConnect (with a trial license), but I keep getting the error: "Failed to find or load the registered .Net Framework Data Provider."
Please update the provider version (5.70.152.0 -> 9.4.326.0) in your app.config either manually or via Tools > Oracle > Upgrade Wizard.

You can check your current version of dotConnect for Oracle via Tools > Oracle > About.

Code: Select all

...
            <add assembly="Devart.Data.Oracle, Version=9.4.326.0, Culture=neutral, PublicKeyToken=09AF7300EEC23701"/></assemblies>
...
<system.data>
  <DbProviderFactories>
    <remove invariant="Devart.Data.Oracle" />
    <add name="dotConnect for Oracle" invariant="Devart.Data.Oracle" description="Devart dotConnect for Oracle" type="Devart.Data.Oracle.OracleProviderFactory, Devart.Data.Oracle, Version=9.4.326.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
  </DbProviderFactories>
</system.data>
</configuration>

Post Reply