dbConnet 9.4.299 not compatible with netcoreapp1.1

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
ilumnoInt
Posts: 4
Joined: Tue 11 Jul 2017 19:50

dbConnet 9.4.299 not compatible with netcoreapp1.1

Post by ilumnoInt » Tue 11 Jul 2017 20:04

Hi all.

I am getting the folowing error when trying to install dbConnet version 9.4.299 from NuGet : dotConnect.Express.for.Oracle 9.4.299 is not compatible with netcoreapp1.1

The target environment is class library and Web Api project in VS 2017 The framework is .NetCore 1.1.

Code: Select all

PM> Install-Package dotConnect.Express.for.Oracle
  GET https://api.nuget.org/v3/registration2-gz/dotconnect.express.for.oracle/index.json
  OK https://api.nuget.org/v3/registration2-gz/dotconnect.express.for.oracle/index.json 198ms
Restoring packages for C:\Users\Edgar Pabani\Documents\GIT Projects\Banner\master\BannerWebAPI\Banner.Core.DataModel\Banner.Core.DataModel.csproj...
Install-Package : Package dotConnect.Express.for.Oracle 9.4.299 is not compatible with netcoreapp1.1 
(.NETCoreApp,Version=v1.1). Package dotConnect.Express.for.Oracle 9.4.299 supports: net (.NETFramework,Version=v0.0)
At line:1 char:1
+ Install-Package dotConnect.Express.for.Oracle
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Install-Package], Exception
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand
 
Install-Package : One or more packages are incompatible with .NETCoreApp,Version=v1.1.
At line:1 char:1
+ Install-Package dotConnect.Express.for.Oracle
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Install-Package], Exception
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand
 
Install-Package : Package restore failed. Rolling back package changes for 'Banner.Core.DataModel'.
At line:1 char:1
+ Install-Package dotConnect.Express.for.Oracle
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Install-Package], Exception
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand
 
Time Elapsed: 00:00:02.5925618
Should it be installed manually?

Thanks

Shalex
Devart Team
Posts: 8082
Joined: Thu 14 Aug 2008 12:44

Re: dbConnet 9.4.299 not compatible with netcoreapp1.1

Post by Shalex » Wed 12 Jul 2017 17:04

dotConnect.Express.for.Oracle is compatible with .NET Framework.

Devart.Data.Oracle is compatible with .NET Standard 1.3 (.NET Core).

JIC: viewtopic.php?t=35459#p123288

Post Reply