Compiling using .net Framework 3.5

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Cla Software Dev
Posts: 1
Joined: Tue 18 Oct 2016 08:50

Compiling using .net Framework 3.5

Post by Cla Software Dev » Tue 18 Oct 2016 09:09

Hi,

our product is using DotConnect for Oracle 9.0.26, standard version.
We compile our product with .net framework 3.5 in order to maintain compatibility with windows XP and Windows Server 2003 operating systems.

On some computers or virtual machines our product is extremely slow when it tries to load Devart.Data.Oracle.Dll and Devart.Data.Dll assemblies.
If we compile our product with .net framework 4.0 or 4.5 we didn't see any delay on assemblies loading.

We didn't yet discovered the real reason why on some computers the assemblies loading process is so slow, when on other computers everything is fine.

Do you have any idea?
Of course the solution is to re-compile our product with framework 4.0 or higher but, as i told you, we have to maintain the compatibility with older version of Windows operating system.

Thanks in advance.

Pinturiccio
Devart Team
Posts: 2192
Joined: Wed 02 Nov 2011 09:44

Re: Compiling using .net Framework 3.5

Post by Pinturiccio » Wed 19 Oct 2016 15:04

This is a strange behaviour. The Devart assemblies of dotConnect for Oracle are built with .NET Framework 2.0. .NET Framework loads Devart assemblies, and the speed of loading depends on the Framework itself.

Could you please describe how exactly you measured the assembly loading speed. How did you find out that this is assembly loading that takes much time, and not query execution against the database or some other operation?

Please also provide your connection string (roughly, without credentials).

Post Reply