EntityFramework 6.1.2 Support

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
BGrojer
Posts: 18
Joined: Thu 19 Sep 2013 12:35

EntityFramework 6.1.2 Support

Post by BGrojer » Tue 20 Jan 2015 15:42

Hi,

is EF 6.1.2 already supported by Version 8.4.333?

We saw quite a lot of broken queries (when includes are used) if EF 6.1.2 is used instead of 6.1.2.

Any Feedback on that?

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: EntityFramework 6.1.2 Support

Post by Shalex » Wed 21 Jan 2015 15:58

Please describe the problem you have encountered.

If the issue is caused by generating unnecessary OUTER APPLY, it should be fixed in upcoming 6.1.3: https://entityframework.codeplex.com/workitem/2612. As a temporary workaround, downgrade to 6.1.1.

BGrojer
Posts: 18
Joined: Thu 19 Sep 2013 12:35

Re: EntityFramework 6.1.2 Support

Post by BGrojer » Thu 22 Jan 2015 09:10

A simple query with multiple includes leads to the mentioned error.

A reproduce is super simple. Just doing a query with multiple includes leads to the issue:

var query = from o in dbContext.ObjectA
.Include("A")
.Include("A.B")
.Include("AA")
.Include("BB.C)
where O.ID == 123
select o;

I generated SQL is broken. (unable to execute that in SQL developer). There is no let keyword and also no TPH or TPT mapping for the mentioned tables in place.

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: EntityFramework 6.1.2 Support

Post by Shalex » Fri 23 Jan 2015 13:47

Please give us the following information:
1) the exact text of the error and its call stack
2) the generated SQL which fails to execute (for this, enable dbMonitor)
3) send us a small complete test project with the corresponding DDL script

BGrojer
Posts: 18
Joined: Thu 19 Sep 2013 12:35

Re: EntityFramework 6.1.2 Support

Post by BGrojer » Mon 02 Feb 2015 09:47

Issue with DevArt Sql Generator confirmed by EF team. Reproduce provided to you guys.

Related bug on EF site could be found here:
https://entityframework.codeplex.com/workitem/2653

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: EntityFramework 6.1.2 Support

Post by Shalex » Mon 02 Feb 2015 14:58

Thank you for your test project.
We have reproduced the issue with incorrect SQL generation when using EFv6.1.2. We will notify you about the results of our investigation.

As a temporary workaround, please use EFv6.1.1.

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: EntityFramework 6.1.2 Support

Post by Shalex » Wed 18 Feb 2015 13:14

The issue is fixed in EFv6.1.3 (http://entityframework.codeplex.com/workitem/2653).
You can use the corresponding nightly build now. For this, execute the following command in your Package Manager Console:

Code: Select all

Install-Package EntityFramework -Version 6.1.3-rc1-40216 -Source https://www.myget.org/F/aspnetwebstacknightly -IncludePrerelease

Post Reply