Connection string with Number Mapping ignored by Entity Developer?

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
c.harlass
Posts: 2
Joined: Thu 30 Oct 2014 16:41

Connection string with Number Mapping ignored by Entity Developer?

Post by c.harlass » Thu 30 Oct 2014 17:05

Hi,

I have an Oracle table with a NUMBER(18,3) column, which should be mapped as System.Double.

When I follow the docu and add number mappings, they will be ignored when adding the table to the designer. I have been trying: "Number Mappings=(NUMBER,11,38,System.Double)", "Number Mappings=(NUMBER,18,3,System.Double)".

Any help would be greatly appreciated.
Thx, Chris

PS: Oracle 10g, DevArt 8.4.201, EF 6.1.1

Shalex
Devart Team
Posts: 8083
Joined: Thu 14 Aug 2008 12:44

Re: Connection string with Number Mapping ignored by Entity Developer?

Post by Shalex » Fri 31 Oct 2014 07:51

c.harlass wrote:Connection string with Number Mapping ignored by Entity Developer?
That is a designed behaviour.

Here is a default mapping: http://www.devart.com/dotconnect/oracle ... pping.html.
If necessary, you can change default mapping:
1) via the Tools > Options > Servers' Options > Oracle menu (applied only for Entity Developer, *.edml)
2) using the Number Mappings connection string parameter (applied only for EDM Wizard, *.edmx)

c.harlass
Posts: 2
Joined: Thu 30 Oct 2014 16:41

Re: Connection string with Number Mapping ignored by Entity Developer?

Post by c.harlass » Fri 31 Oct 2014 12:54

Thanks, works now!

Post Reply