Entity Framework Connection String not working with dotConnect

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
ScottSEA
Posts: 8
Joined: Thu 18 Apr 2013 21:23

Entity Framework Connection String not working with dotConnect

Post by ScottSEA » Tue 23 Apr 2013 19:59

My Oracle DBA says that my new (but obfuscated) connection string should look like this:

Code: Select all

jdbc:oracle:thin:@/oidlbr.aaa.mysite.com:2345/dbname,cn=OracleContext,dc=mysitedb
My previous connection string (before a server migration and upgrade to Oracle 11g) looked like this:

Code: Select all

		<add name="AuthorizationEntities" connectionString="metadata= res://Config.Domain/DataModels.Authorization.OurDataModel.csdl|			                             res://Config.Domain/DataModels.Authorization.OurDataModel.ssdl|										 res://Config.Domain/DataModels.Authorization.OurDataModel.msl;
provider=Devart.Data.Oracle;
provider connection string="User Id=myId;Password=*********;Server=asdf.fds.mysite.com;Direct=True;Sid=dbname"" providerName="System.Data.EntityClient" />
Try as I might I cannot get this to fly. Can anyone please assist me in changing my connection string to this new & "improved" string?

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Entity Framework Connection String not working with dotConnect

Post by Shalex » Tue 30 Apr 2013 10:43

Currently dotConnect for Oracle does not support LDAP. We are investigating the possibility of implementing this feature.

Post Reply