Workflow getInstance fails

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
fifty
Posts: 1
Joined: Thu 21 Feb 2013 12:55

Workflow getInstance fails

Post by fifty » Thu 21 Feb 2013 13:06

hi,

I have a WPF application with a workflow, which is persisted when state is Idle. After the persist action I check the database and INSTANCESTABLE contains the right instance. Then I try to obtain the instance with:

Code: Select all

    WorkflowApplicationInstance instance =
                WorkflowApplication.GetInstance(WorkflowInstanceId, GetStore());
and I always get the following error:
The execution of an InstancePersistenceCommand was interrupted because the instance owner registration has become invalid. This error indicates that the in-memory copy of all instances locked by this owner have become stale and should be discarded, along with the InstanceHandles. Typically, this error is best handled by restarting the host.
This is how my store is configured:

Code: Select all

var store = new Devart.Data.Oracle.DurableInstancing.OracleInstanceStore(OracleDbConnectionString)
                {
                    HostLockRenewalPeriod = new TimeSpan(0, 0, 10),
                    RunnableInstancesDetectionPeriod = new TimeSpan(0, 0, 10)
                };
Even if I wait 2-3 minutes, I get the same.
In the database the LOCKOWNERSTABLE table contains a row, should not this row deleted when HostLockRenewalPeriod exceeds and move the instance to the RUNNABLEINSTANCESTABLE?

thx,
fifty

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Workflow getInstance fails

Post by Shalex » Fri 22 Feb 2013 17:35

We have reproduced the error and are investigating the issue.

mksabre
Posts: 1
Joined: Wed 27 Feb 2013 15:51

Re: Workflow getInstance fails

Post by mksabre » Wed 27 Feb 2013 15:58

Hi,

Any update on this? I'm facing the same problem.

MK

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Workflow getInstance fails

Post by Shalex » Mon 04 Mar 2013 13:57

We are going to include the fix in the next public build of dotConnect for Oracle. We will post here about the result.

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Workflow getInstance fails

Post by Shalex » Fri 05 Apr 2013 12:35

New version of dotConnect for Oracle 7.7 is released!
It can be downloaded from http://www.devart.com/dotconnect/oracle/download.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?f=1&t=26313.

EmilyFong
Posts: 12
Joined: Sun 20 May 2012 04:25

Re: Workflow getInstance fails

Post by EmilyFong » Tue 07 May 2013 11:38

I already used the latest version (7.7.216.0), but still fail.

Shalex
Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Re: Workflow getInstance fails

Post by Shalex » Wed 08 May 2013 07:28

Please create a new schema using the scripts from the \Program Files\Devart\dotConnect\Oracle\WF Services\NET45 folder and add the reference to the new \Program Files\Devart\dotConnect\Oracle\WF Services\NET45\Devart.Data.Oracle.WorkflowFoundation.dll assembly. Does it work?

Post Reply