Telerik reporting and dotConnect

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
kurtbilde
Posts: 113
Joined: Wed 16 Mar 2005 16:02
Location: Odense, Denmark

Telerik reporting and dotConnect

Post by kurtbilde » Mon 21 Jan 2013 14:19

Hi,

Anyone succeded in using Telerik reporting with dotConnect?!? Especialy the stand-alone report designer and the data source settings...

TIA
Kurt

Pinturiccio
Devart Team
Posts: 2141
Joined: Wed 02 Nov 2011 09:44

Re: Telerik reporting and dotConnect

Post by Pinturiccio » Fri 25 Jan 2013 09:42

We didn't test our provider with Telerik. dotConnect for Oracle implements standard ADO.NET interfaces, and thus can be used with Telerik as any other ADO.NET provider. If you have discovered a particular problem caused by our provider, please send us a test project.

We have also tried to create a simple Telerik Report, described in their documentation:
http://www.telerik.com/help/reporting/q ... eport.html
In step 7 we selected dotConnect for Oracle as a Data Provider. The rest of the steps were performed according to the tutorial, and a Telerik Report was created successfully.

kurtbilde
Posts: 113
Joined: Wed 16 Mar 2005 16:02
Location: Odense, Denmark

Re: Telerik reporting and dotConnect

Post by kurtbilde » Mon 28 Jan 2013 12:42

Hi,

In the standand alone, you can select "dotConnect for Oracle" as Data provider, but are unable to build the connection string.

-Kurt

Pinturiccio
Devart Team
Posts: 2141
Joined: Wed 02 Nov 2011 09:44

Re: Telerik reporting and dotConnect

Post by Pinturiccio » Mon 28 Jan 2013 15:38

You are right, the Build button is disabled for the connection string, when dotConnect for
Oracle is selected as a data provider. The same behavior can be observed with Oracle Data Provider for .NET.
Try entering the connection string manually into the text field to the left of the Build button, for example, as follows:

Code: Select all

host=your host; password=your password; user id=your user id;

kurtbilde
Posts: 113
Joined: Wed 16 Mar 2005 16:02
Location: Odense, Denmark

Re: Telerik reporting and dotConnect

Post by kurtbilde » Sun 03 Feb 2013 19:00

And it works!!!!

Thanks

-Kurt

Post Reply