Stored Procedure Parameter with Entities

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 1
Joined: Thu 04 Oct 2012 06:43

Stored Procedure Parameter with Entities

Post by adi » Thu 04 Oct 2012 06:56


We are using dotConnect for Oracle 6.3 in direct Mode. We have a SP with about 40 Parameters (in number).
We use the Entity Model to invoke the Procedure. It fails with:

"NET: Unknown error 1"

bei Devart.Data.Oracle.DirectUtils.b(Int32 A_0)
bei Devart.Data.Oracle.DirectUtils.a()
bei A_0)
bei A_0)
bei Devart.Data.Oracle.cp.a()
bei Devart.Data.Oracle.aj.a(bp A_0)
bei Devart.Data.Oracle.u.a()
bei Devart.Data.Oracle.ah.a(String A_0, Int32 A_1)
bei Devart.Data.Oracle.aj.a(String A_0, Int32 A_1)
bei Devart.Data.Oracle.OracleCommand.DescribeProcedure(String name)
bei Devart.Data.Oracle.OracleCommand.CreateStoredProcSql(String procName)
bei Devart.Common.DbCommandBase.CreateSql()
bei Devart.Common.DbCommandBase.get_Sql()
bei Devart.Data.Oracle.OracleCommand.InternalPrepare(Boolean implicitPrepare, Int32 startRecord, Int32 maxRecords)
bei Devart.Common.DbCommandBase.ExecuteDbDataReader(CommandBehavior behavior, Boolean nonQuery)
bei Devart.Common.DbCommandBase.ExecuteDbDataReader(CommandBehavior behavior)
bei System.Data.Common.DbCommand.ExecuteReader(CommandBehavior behavior)
bei Devart.Data.Oracle.Entity.e.a(CommandBehavior A_0)
bei Devart.Common.Entity.ak.b(CommandBehavior A_0)
bei Devart.Data.Oracle.Entity.e.b(CommandBehavior A_0)
bei System.Data.Common.DbCommand.ExecuteReader(CommandBehavior behavior)
bei System.Data.EntityClient.EntityCommandDefinition.ExecuteStoreCommands(EntityCommand entityCommand, CommandBehavior behavior)

I tried with fewer Parameters and it worked...has dotConnect for Oracle a Parameter limitation in conjunction with .NET Entities?

Thank you

Devart Team
Posts: 8088
Joined: Thu 14 Aug 2008 12:44

Re: Stored Procedure Parameter with Entities

Post by Shalex » Thu 04 Oct 2012 11:40

Thank you for the report but we cannot reproduce the described scenario with dotConnect for Oracle v 7.2.77. Could you please try the latest build? If this doesn't help, send us a small test project with the corresponding DDL/DML script so that we can reproduce the issue in our environment.

Post Reply