License Version is wrong

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 5
Joined: Thu 30 Aug 2012 13:26

License Version is wrong

Post by HolgerM » Fri 31 Aug 2012 09:37


I installed dotConnect for Oracle (Version 7.1.40) to investigate this component for our software. During my tests i came across the bug "The bug with the OracleDbType.Char command parameter when using the "Unicode=true;" connection string parameter in the Direct Mode is fixed".
I downloaded latest Version 7.1.58, uninstalled old version and installed new Version.
Now i got some problems:

1. Running App on develop host with dotConnect installed and local copy of Devart.*.dll
-> fails, Exception occurs because Array for converting with unicode is to small. It seems to be the same Bug you already fixed.
2. Running App on any other host (Windows or Linux) works fine.

I used DirectMode and Unicode for my Connection.

-> Whats wrong?
I looked in licenses.licx and see:
Devart.Data.Oracle.OracleConnection, Devart.Data.Oracle, Version=, Culture=neutral, PublicKeyToken=09af7300eec23701
-> I tried to fix it by removing licenses.licx from my project and create a new one by "Licence Information" Dialog.
"Add dotConnect for Oracle license information to licenses.licx
Devart.Data.Oracle.OracleConnection, Devart.Data.Oracle, Version=, Culture=neutral, PublicKeyToken=09af7300eec23701"

The new licenses.licx contains again the Version 7.1.40 and not 7.1.58.

During Debug i looked at the loaded Version of Devart.Data.Oracle and loaded version is 7.1.58.

I also tried with no success.

Please help me!
I would like to buy your product, but if my investigation is not succesfully i can do so ...


Devart Team
Posts: 2192
Joined: Wed 02 Nov 2011 09:44

Re: License Version is wrong

Post by Pinturiccio » Mon 03 Sep 2012 13:55

Please do the following:
1. uninstall dotConnect for Oracle;
2. remove all Devart.* and policy.*.Devart.* files from the GAC;
3. clear the Program Files\Devart\dotConnect and Program Files\Common Files\Devart\dotConnect folders;
4. reinstall dotConnect for Oracle;
5. delete all files from the bin and obj folders and rebuild the project;
6. delete your licenses.licx file and recreate it;
7. rebuild the project.

Post Reply