Error generating model file with FunctionImport

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
object
Posts: 89
Joined: Tue 26 Oct 2010 08:29

Error generating model file with FunctionImport

Post by object » Mon 12 Dec 2011 14:06

Hi,

Starting apprx. from previous version, I have to manually edit models generated with dotConnect for Oracle if they have FunctionImport section.

There is an EntitySet DistributionFiles, and here is the definition that works:





Here's the one that causes problems (error from custom tool run):





I.e. inclusion of "EntitySet" attribute causes the error, and dotConnect includes it.

NB! Actually the situation is even more complicated. I first need to remove "EntitySet" attribute to be able to run custom tool, and then once the C# entity file is generated I need to bring FunctionImport EntitySet attitbute back to the model file.

Shalex
Devart Team
Posts: 8088
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 15 Dec 2011 14:56

Thank you for your report. We have reproduced the problem. We will notify you when it is fixed.

Shalex
Devart Team
Posts: 8088
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Mon 19 Dec 2011 17:51

The bug with duplicating EntitySet attribute when using entity return type is fixed. We will post here when the corresponding build of dotConnect for Oracle is available for download.

Shalex
Devart Team
Posts: 8088
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 22 Dec 2011 17:30

New build of dotConnect for Oracle 6.60.268 is available for download now!
It can be downloaded from http://www.devart.com/dotconnect/oracle/download.html (trial version) or from Registered Users' Area (for users with valid subscription only).
For more information, please refer to http://www.devart.com/forums/viewtopic.php?t=22977 .

Post Reply