Error trying to insert more than 664 chars to NVARCHAR(2000)

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 6
Joined: Wed 04 May 2011 06:43
Location: Finland

Error trying to insert more than 664 chars to NVARCHAR(2000)

Post by AnssiA » Wed 04 May 2011 06:54

I'm using Entity Framework and when i'm trying to insert more than 664 chars to NVARCHAR(2000) column, I get error:

ORA-01460: unimplemented or unreasonable conversion requested
at Devart.Data.Oracle.w.a(Int32 A_0, bk A_1)
at Devart.Data.Oracle.OracleCommand.InternalExecute(CommandBehavior behavior, IDisposable disposable, Int32 startRecord, Int32 maxRecords, Boolean nonQuery)
at Devart.Common.DbCommandBase.ExecuteDbDataReader(CommandBehavior behavior, Boolean nonQuery)
at Devart.Data.Oracle.Entity.a.c.a(CommandBehavior A_0)
at Devart.Data.Oracle.Entity.a.c.b(CommandBehavior A_0)
at System.Data.Mapping.Update.Internal.DynamicUpdateCommand.Execute(UpdateTranslator translator, EntityConnection connection, Dictionary`2 identifierValues, List`1 generatedValues)
at System.Data.Mapping.Update.Inter...).

Currently using DotConnect but I have tried also 6.30 Beta with no luck.

Devart Team
Posts: 8088
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 06 May 2011 14:14

I cannot reproduce the problem with the 6.30.145 Beta version of dotConnect for Oracle neither in OCI, nor in Direct modes. I have also tried using the Unicode connection string parameter.

Please specify your mode (OCI or Direct), connection string (roughly, without credentials) and send us a small test project with the corresponding DDL/DML script so that we can reproduce the issue in our environment.

Post Reply