dotConnect 6.10 not working for .NET <4

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 5
Joined: Wed 06 Apr 2011 13:45

dotConnect 6.10 not working for .NET <4

Post by Species8372 » Wed 06 Apr 2011 13:58

Hello everyone,

i just updated to your current Version 6.10 and detected that my .NET3.5 Profile Project is no longer working. Devart.Data.Oracle.Entity has some Reference to System.Xaml which is not available in .NET<4.0?

Will this be resolved, or can i work around it?

Another question, when installing the new Version on my development machine (6.10) and still delivering the old devart-drivers 5.70 - will the licensing than still work?



Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Thu 07 Apr 2011 08:01

Please make sure that you have added the reference to the correct Devart.Data.Oracle.Entity assembly.
There are two versions - for .NET 4.0 and for prior versions of .NET.
Take a look at this answer for detailed description of the situation with several versions of dotConnect on one development machine.

Post Reply