Cannot find data provider

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
riquecosta
Posts: 3
Joined: Tue 22 Mar 2011 19:08

Cannot find data provider

Post by riquecosta » Tue 22 Mar 2011 19:14

Hi people, Im trying use direct connect (Oracle) and I m getting this error:
Cannot find data provider

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 23 Mar 2011 07:58

Are you getting this error in your production environment (where dotConnect for Oracle is not installed)? If yes, please make sure that you have registered the provider factory in the *.config file: http://www.devart.com/dotconnect/oracle ... yment.html.

If this doesn't help, please specify:
1) the version (x.xx.xxx) and edition of your dotConnect for Oracle. You can find it in the Tools > Oracle > About menu of Visual Studio;
2) the exact text of the error and your stack trace;
3) if possible, send us a small test project to reproduce the error in our environment.

riquecosta
Posts: 3
Joined: Tue 22 Mar 2011 19:08

Post by riquecosta » Wed 23 Mar 2011 11:48

hi,
Yes, this error occurs in my production environment.
As recommended, i put the code below in my web.config








then I put Devart.Data.Oracle.Entity.dll and Devart.Data.Oracle.Web.dll in Bin folder.

Now, the error changes to: Failed to locate or load the provider. NET Framework Data registered

I don't what is wrong...

AndreyR
Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Wed 23 Mar 2011 16:08

Please add Devart.Data.dll and Devart.Data.Oracle.dll assemblies to the Bin folder of the application that is being deployed. This should help.

riquecosta
Posts: 3
Joined: Tue 22 Mar 2011 19:08

Work

Post by riquecosta » Wed 23 Mar 2011 16:19

Dlls added and works fine.
Tks a lot!!!!!
:D

Post Reply