ORA-24778 : cannot open connections

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 1
Joined: Fri 11 Feb 2011 11:37

ORA-24778 : cannot open connections

Post by acs-inc » Fri 11 Feb 2011 11:53

- .NET Framework 4.0
- Oracle database 10GR2

I'm experiencing problems in using Dotconnect for Oracle in this particular context :

- My app connects on database A
- From A, I select data on a remote database B, using a database link
- Then I call a package PL/SQL function which first performs another select on data located on B

=> This select fails, returning ORA-24778 : cannot open connections

Oracle says :
"Cause: The migratable transaction tried to access a remote database when the session itself had opened connections to remote database(s)."
"Action: Close the connection(s) in the session and then try to access the remote database from the migratable transaction. If the error still occurs, contact Oracle customer support."

I didn’t find out what had to be done to fix that problem ; A very few people on the web is talking about this error, and it didn't help me.

Other tests :
- the same actions performed on Oracle SQL*Plus client worked fine
- everything works also fine, if data is located on database A and not on remote database B (no use of database link).

Maybe something to configure about the connection pool or the transaction properties ?

Thank you for your help.

Site Admin
Posts: 8245
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Mon 14 Feb 2011 14:26

We have just sent a test project to your e-mail. Please try it.

Post Reply