Need Help

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 43
Joined: Mon 13 Oct 2008 13:23

Need Help

Post by edstaffin » Tue 11 Jan 2011 12:34


We can connection to our db using sql developer or sql/Plus with a username and password without problems. However when we try to update a table in another schema using the form schemaname.tablename, we get a login denied error from oracle when using dotconnect.
The line of code was something like:
db.ExecuteCommand("delete from CGSDB.Temp_Prism")

At the same time, I can connect to the database using the database explorer, but it does not show ANY objects. Yet the username does have permissions to a variety of tables and procs from another schema etc.

Is there a way to reference objects in another schema in the explorer?

Thanks … Ed

Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Tue 11 Jan 2011 18:18

1. I have tried to reproduce the problem with the 6.0.70 version of dotConnect for Oracle using both Direct and OCI modes. It works OK with the Devart.Data.Oracle.OracleCommand object. I just granted this privilege to the user I opened connection with:

Code: Select all

GRANT DELETE ON CGSDB.Temp_Prism TO name_of_connected_user;
After this, the following command was executed successfully:

Code: Select all

oracleCommand.ExecuteNonQuery("delete from CGSDB.Temp_Prism");
2. The "Show All Objects" option is available in Database Explorer that is included into OraDeveloper Tools.

Give us the following information:
1) the version (x.xx.xx) of dotConnect for Oracle you are using. You can find it in the Tools > Oracle > About menu of Visual Studio;
2) the class your db object is instance of;
3) have you tried to grant the DELETE privilege on CGSDB.Temp_Prism to the user you are connecting with via dotConnect for Oracle?
4) give us the exact text of the error and its call stack.

Post Reply