Strange issue with obfuscation toolkit

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 11
Joined: Mon 09 Nov 2009 21:26

Strange issue with obfuscation toolkit

Post by mkashyap » Wed 10 Nov 2010 21:27

We are using Oracle's Sys.DBMS_Obfuscation toolkit to encrypt/decrypt strings.

While decrypting the string we are getting this error--"ORA-28232: invalid input length for obfuscation toolkit"

I am calling this through a DB package and setting up the parameters, command text is set to stored procedure and doing a ExecuteNonQuery on the command object.

However, what is strange about it is, this error is occurring only when using the word "rgoodman" and while making the oracle connection with direct = false.

The same word works when the connection is created using the direct mode.

The same word in uppercase works in both modes. I have tried several other words both lower case and uppercase, tried different combination of letters, all worked except this one word.

This also works if I set the command text as text and called the ExecuteScalar on the command object.

I have tested this on versions 5.70 version of Devart and earlier version with the same result.

This is really strange and I am not sure where the issue is. Could you throw some light on this?


Devart Team
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Post by StanislavK » Fri 12 Nov 2010 16:31

Could you please describe how exactly you are configuring and executing OracleCommand when this error occurs? If possible, please send us a test project so that we are able to reproduce and investigate the issue.

Post Reply