AD Authentication to Oracle

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Emily
Posts: 13
Joined: Mon 30 Nov 2009 23:45

AD Authentication to Oracle

Post by Emily » Wed 06 Oct 2010 16:50

I can't seem to connect my application that runs on Windows Server that is accessed via the web (ASP.NET MVC) to an Oracle instance that runs on Linux.

I have the following in the web.config:

Code: Select all

<connectionStrings>
<add name="ProjectEntities" connectionString="metadata=res://*/XModel.csdl|res://*/XModel.ssdl|res://*/XModel.msl; provider=Devart.Data.Oracle; provider connection string='Server=PROD;Persist Security Info=True'" providerName="System.Data.EntityClient" />
</connectionStrings>
...
<authentication mode="Windows" /> 
---------------
I also disabled Anonymous Access on ISS and checked Windows Authentication.

I even tried trying to set and kept on getting 'provider failed to open' message.

My application works if I include credentials in the connection string. I can even log onto that server and use SQL*Plus to try /@PROD and that works.

Am I able to do this with your Oracle dotConnect?

Shalex
Site Admin
Posts: 8247
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 07 Oct 2010 17:08

OS Authentication in the OCI mode of dotConnect for Oracle should work. We will investigate the issue.
1. Is there any internal exception?
2. Please try connecting to Oracle using OS Authentication via OracleConnection class (create a simple console application, create the OracleConnection class, set its connection string as "Server=PROD;", and call Open()). Does it work?

Post Reply