License issue when using build server (Luntbuild)

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
dbelanger
Posts: 6
Joined: Wed 23 Sep 2009 17:24

License issue when using build server (Luntbuild)

Post by dbelanger » Thu 24 Jun 2010 00:22

Hello,

I've run into a problem with the license when promoting my .NET application through our environments. It worked fine on our dev server but upon the latest promotion to our staging server I receive this error when I run the app:

Devart.Data.Oracle.OracleException: License not valid due to the problems with dotConnect for Oracle installation.

I'm not sure why it would work on the one server and not the other. I'm using direct mode to connect. Any help would be greatly appreciated.

Thanks
Last edited by dbelanger on Thu 24 Jun 2010 20:59, edited 1 time in total.

Shalex
Devart Team
Posts: 8082
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 24 Jun 2010 10:52

Make sure that your application has a valid license resource. Please refer to http://www.devart.com/dotconnect/oracle ... nsing.html, determine the type of your application and add the technical lisence. Otherwise, you can run our license wizard (the Tools > Oracle > License Information menu of Visual Studio) that helps to add the technical lisence automatically (press the Fix button near the problem description).

If the problem persists, please tell us the type of your application (WinForms, ASP.NET Applicatoin, WebSite, etc) and the content of the License Information window.

dbelanger
Posts: 6
Joined: Wed 23 Sep 2009 17:24

Post by dbelanger » Thu 24 Jun 2010 17:33

I was able to get this to work by manually compiling the license. Thanks for your help.

Post Reply