ORA-01036 illegal variable name/number

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 1
Joined: Wed 19 May 2010 00:31
Location: Pasadena

ORA-01036 illegal variable name/number

Post by JustinA » Wed 19 May 2010 00:41

I have tried almost everything under the sun to get an ext.js gridpanel to save correctly using the dotConnect tool and so far no luck. Everything I have tried gets the ORA-01036 error. What I can do is get the update statement to work if I manually enter the update value and the where clause value (to test the connection string and field names etc). But once I enter the field parameter values I get the ORA-01036 error message. For this test, the Oracle table only has the two fields. They are both Number fields. I tried the Original_ variable for the where clause variable and I get the same error message.

Here is the code:



Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 21 May 2010 16:39

Please use the Original_ prefix with the parameter that is used in the WHERE clause. Refer to http://www.devart.com/forums/viewtopic.php?t=14441.
1. Have you tried the latest 5.70.140 build of dotConnect for Oracle?
2. Are you using the Direct or OCI mode?

If the tips from the mentioned thread don't help, please send us a small test project with the DDL/DML script to reproduce the error in our environment. Also tell us your current versions of dotConnect for Oracle (x.xx.xx), Oracle Server, Oracle Client (if the OCI mode is used).

Post Reply