Licence not foud... - phenomenon

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 13
Joined: Mon 11 Aug 2008 12:45

Licence not foud... - phenomenon

Post by markaw » Thu 22 Apr 2010 12:37


I have a strange phenomenon with licensing. I moved my software (ASP.NET) to a virgin Windows Server machine. I have licenses file as an embedded resource. It worked fine on other machine. On the new machine I got immediately "Licence not foud.." exception. I've tried to compile anew - same effect. What helped? Installing and deinstalling your driver from dcoracle560pro.exe. After this operation everything works like a charm? What is going on? Do you leave something in machine.config?

PS. The driver was NOT installed on previous machine but I cannot rule out the possibility that it was installed earlier and than deinstalled.

Best reagrds,

Devart Team
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Post by StanislavK » Fri 23 Apr 2010 15:25

dotConnect for Oracle inserts an entry to the DbProviderFactories node of machine.config: ... yment.html
This entry is necessary, e.g., for Entity Framework and web applications.

Please specify the versions of dotConnect for Oracle and .NET Framework you are using. Did you install the same version that was installed before re-installing dotConnect for Oracle?

Post Reply