5.35.57 bug in Membership provinder

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
dqminh
Posts: 28
Joined: Wed 12 Nov 2008 01:31

5.35.57 bug in Membership provinder

Post by dqminh » Tue 15 Dec 2009 09:22

Hi,

The membership query:

Code: Select all

MembershipUserCollection users = prv.FindUsersByName(filter, 0, int.MaxValue, out count);
filter is username, and the sql is (from monitor)

Code: Select all

SELECT username, password, u.userid, email, passwordquestion, passwordanswer, comments, isapproved, islockedout, creationdate, lastlogindate, lastactivitydate, lastpasswordchangeddate, lastlockoutdate FROM aspnet_membership m, aspnet_users u WHERE u.userid = m.userid AND LOWER(u.applicationname) = :applicationname order by username AND LOWER(username) LIKE :username
Please fix it!

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 17 Dec 2009 11:34

We have put the ORDER BY clause in the right place and sent you the fixed Devart.Data.Oracle.Web.dll assembly by e-mail.

dqminh
Posts: 28
Joined: Wed 12 Nov 2008 01:31

Post by dqminh » Mon 28 Dec 2009 11:25

Shalex wrote:We have put the ORDER BY clause in the right place and sent you the fixed Devart.Data.Oracle.Web.dll assembly by e-mail.
Sorry, today I check the assembly that you sent, and do as your guide, but the error in the web.config (before replace your assembly, no problem):

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Exception has been thrown by the target of an invocation.

Line 6:

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Mon 28 Dec 2009 14:31

We had checked the assembly before sending it to you. It worked in our environment. Probably, something is wrong with your application settings:
1) please compare your web.config entry with the one from our sample (\Program Files\Devart\dotConnect\Oracle\Samples\Web\CS\WebProviders\web.config);
2) fill the applicationName attribute with the name of your application;
3) try to obtain a more detailed description of the problem.
If this doesn't help, please send us a small test project. We will try to reproduce the issue in our environment.

dqminh
Posts: 28
Joined: Wed 12 Nov 2008 01:31

Post by dqminh » Tue 29 Dec 2009 08:08

I've checked again, and it work. Thanks.

Post Reply