Mono support

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
jp.gouigoux
Posts: 20
Joined: Tue 09 Jun 2009 10:23

Mono support

Post by jp.gouigoux » Tue 09 Jun 2009 10:28

Hello,

I would like to know which version of Mono is currently supported. I found an old post explaining 1.9 was under validation, but nothing newer. Is 2.0 validated ? Is 2.4 under validation ?

Also, there seems to be a problem with RegistryKey, potentially linked to the fact that the licensing cannot be done directly under Mono. Is there a way I can do that with a trial version ? I need to validate that OraDirect.NET for Oracle works fine with Linux Mono before buying...

Thanks in advance for your help,

JP

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 10 Jun 2009 08:37

1. dotConnect for Oracle supports Mono version 2.0 and above. We have checked its core functionality with OpenSUSE 11.1 and Mono 2.4.

2. You are right. Licensing cannot be done directly under Mono. It is necessary to generate the license resource using License Compiler (Lc.exe) on Windows and embed the result *.licenses file into your application on Linux. Please refer to http://msdn.microsoft.com/en-us/library ... S.80).aspx.

To install dotConnect for Oracle on Linux, run our installation package on Windows and copy the Devart assemblies from the installation folder to your Linux OS.

Luix
Posts: 6
Joined: Tue 24 Nov 2009 16:22

Post by Luix » Thu 26 Nov 2009 13:04

"To install dotConnect for Oracle on Linux, run our installation package on Windows and copy the Devart assemblies from the installation folder to your Linux OS."

Where should I copy those assemblies? In the directory where the project binaries are?

Luix
Posts: 6
Joined: Tue 24 Nov 2009 16:22

Post by Luix » Thu 26 Nov 2009 13:04

"To install dotConnect for Oracle on Linux, run our installation package on Windows and copy the Devart assemblies from the installation folder to your Linux OS."

Where should I copy those assemblies? In the directory where the project binaries are?

That didn't work at all...

Shalex
Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 27 Nov 2009 12:57

You can copy the Devart assemblies to Mono's GAC or to the folder with your project binaries. Please specify the scenario you have chosen and the exact text of the error you are getting.

Post Reply