Licensing

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
mjhillman
Posts: 6
Joined: Wed 28 Jan 2009 14:49
Location: Westville, New Jersey USA

Licensing

Post by mjhillman » Wed 04 Feb 2009 17:55

I had a trial version of dotConnect for Oracle and found to work well in my Visual Studio 2005 Solution. Purchased the product today, uninstalled the trial version, installed the purchased version, and deployed my application and Oracle connectivity did not work. I checked the documentation and tried to follow the directions relative to using the License Wizard but I get an error "Object reference not set to an instance of an object" (twice) when access the menu option, Tools > Oracle > License Information.

I am not using any form components. I only use the provider in my data access layer.

Thanks.
Mike

Shalex
Devart Team
Posts: 8088
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 05 Feb 2009 13:16

1. Please try cleaning the bin and obj folders of your application and, after that, rebuilding your project. Tell us about the results. Probably, your project contains the license resources from the previous (trial) version.
2. Does this problem exist in the new projects?
3.
Oracle connectivity did not work
If the problem persists, please send us an error message and a call stack. In the case you will not manage to get enough information, please make attachment to the process of your Visual Studio from another Visual Studio (to know how to make attachment please refer to http://www.devart.com/forums/viewtopic.php?p=41649 , the last post).

Please notify us about the results.

mjhillman
Posts: 6
Joined: Wed 28 Jan 2009 14:49
Location: Westville, New Jersey USA

Post by mjhillman » Mon 30 Mar 2009 15:44

Why can't I view the licensing information using your wizard?

See the video at this link ...

http://www.screencast.com/t/IyGtBILCEe

Shalex
Devart Team
Posts: 8088
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Tue 31 Mar 2009 13:30

Try licensing your Class Library project manually: http://www.devart.com/dotconnect/oracle ... nsing.html , the Adding License Manually and Class Libraries Support section.

If it doesn't help, please give us the following information:
1) the version (x.xx.xx) and edition of your dotConnect for Oracle;
2) the call stack when the error arises. For this, please make attachment to the process of your Visual Studio from another Visual Studio (to know how to make attachment please refer to http://www.devart.com/forums/viewtopic.php?p=41649 , the last post .
3) all types of the projects that are added to your solution from your video.

Post Reply