RAC Connection

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 3
Joined: Sun 12 Oct 2008 19:15

RAC Connection

Post by cyberpunkpor » Sun 12 Oct 2008 19:20


We have been using OraDirect.NET in our application but allways in DirectMode.

It is possible to explain how we configure the connection string to connect to a RAC?

In Java we use something like:


How do i configure this with OraDirect? Must I use OCI? That implies me to install the Oracle client tools on the server?



Site Admin
Posts: 8241
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Tue 14 Oct 2008 11:00

In direct mode the RAC option of Oracle database is not supported. It is supported in OCI mode. All the parameters of tnsnames.ora have to contain Oracle client settings.

Posts: 3
Joined: Sun 12 Oct 2008 19:15

What is the connection string?

Post by cyberpunkpor » Wed 22 Oct 2008 17:04

What is the connection string to use on OCI?

I have placed the file .ora on the same directory as .config on my IIS application and i turned off Direct Mode.

What i need to do more? Can you paste a sample of a connection string to connect to a RAC .ora file configuration?


Posts: 3
Joined: Sun 12 Oct 2008 19:15


Post by cyberpunkpor » Wed 22 Oct 2008 17:30

I have this exception:

Message: Can not obtain Oracle client information from registry. Check if Oracle
client software installed.

I have installed the Basic on c:\instantclient. The path environment variable is pointing to the directory as:


Any suggestions?

Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Fri 24 Oct 2008 13:37

The instantclient libraries should be put into the current folder (bin).
The machine should not have any other Oracle clients (there are known conflicts associated with registry).
As an alternative, you can use ConnectionString in the following form instead of editing the tnsnames.ora file:

Code: Select all

Please note that application should have permission on unmanaged modules loading.

Post Reply