Problem with charset on OraDirect.NET Mobile

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
softmarek
Posts: 2
Joined: Fri 19 Sep 2008 09:31

Problem with charset on OraDirect.NET Mobile

Post by softmarek » Fri 19 Sep 2008 09:49

Hi,

I have a small (I hope) problem with character set in OraDirect .NET Mobile.
I have different devices. In those, where I can set locale for "Polish", everything works fine.
But there are many devices, in which "Polish " locale is not available. In such environment I receive replies from the server without polish characters - someone (Devart's library, I think) makes a conversion and I receive standard ascii characters.

Is it possible to override system setting (English by default) and disable the conversion at all, or make conversion for polish charset ?
I work with Visual Studio 2008 and VB, so, I believe, I am working with UTF8 and conversions are not needed. Labels in program are displayed on both devices correctly.

I have tried both oracleconnection.unicode settings true and false. With the same result.

Best regards

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 19 Sep 2008 14:28

Tell us please, what is your database encoding?

Code: Select all

select * from nls_database_parameters where parameter='NLS_CHARACTERSET'

softmarek
Posts: 2
Joined: Fri 19 Sep 2008 09:31

Post by softmarek » Fri 19 Sep 2008 14:44

I made tests on different databases, with EE8MSWIN1250 and EE8ISO8859P2 encoding

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Mon 22 Sep 2008 11:19

Character set of obtained data is read really from Encoding.Default.CodePage. Now it cannot be changed. We will investigate the capability of setting it in the needed way.

Post Reply