Error Corelab.Oracle.Vs.OracleDataProviderPackage VS2008

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
tonydoval
Posts: 7
Joined: Sun 03 Jun 2007 18:04

Error Corelab.Oracle.Vs.OracleDataProviderPackage VS2008

Post by tonydoval » Fri 29 Aug 2008 16:47

Hi,
I'm using Windows Vista Sp1, Visual Studio 2008 SP1, and OraDirect .Net Standard 4.75 and when Visual Studio start show this message:

Error load package 'Corelab.Oracle.Vs.OracleDataProviderPackage' GUID = {18F9FE6C-9B00-FBE0-DF0A-29182AA775C3}

How can I fix this?

Best regards.

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Tue 02 Sep 2008 11:26

Please check that you have installed the latest version of OraDirect .NET (4.75.41). You can learn more about this build here: http://www.devart.com/forums/viewtopic.php?t=12786
We have fixed the similar problem in it. If after installation of the latest build the problem persists, please let us know.

saponder
Posts: 3
Joined: Fri 19 Sep 2008 17:27

OraDirect .Net 4.75 Mobile

Post by saponder » Thu 16 Oct 2008 17:08

I am having the exact same issue except with the mobile version.

I was running the mobile trial and it worked perfectly. I just purchased the mobile version from Component Source and downloaded it today and I now get the error.

The package from component source came with 2 exe files, one was oranet475mob.exe and the other was oranet475mob2.exe. If I install the first I don't get the error, but my app will not compile and has all kinds of errors (My app was designed using the trial version). With the second one I get the Package Load Failure message.

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 17 Oct 2008 14:13

Please find out the exact version of OraDirect .NET Moblie Edition you are using. One of the possible ways: Visual Studio, Tools | Oracle Mobile | About OraDirect .NET...

As I understand, this error occurs when you start your Visual Studio. Is it right? Is the error text the same as Tonydoval wrote in the first post in this thread?

I have installed the latest version (4.75.43.1) of OraDirect .NET Mobile Edition. There are no errors when I start my Visual Studio and run our samples from Start menu | All Programs | OraDirect .NET2 Mobile | Samples | C# Samples.

saponder
Posts: 3
Joined: Fri 19 Sep 2008 17:27

OraDirect .Net 4.75 Mobile

Post by saponder » Fri 17 Oct 2008 14:45

Yes, the message is exactly the same. The message only appears at startup of Visual Studio (we are running VS 2008 Team System Edition). The Tools Menu does not have Oracle Mobile, since the package would not load.

The version that I received from Component Source is 4.75.39.1. I am still waiting for a login and password from your office to download the most recent version (we purchased a 4 user team license with 1 year subscription)

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Fri 17 Oct 2008 16:21

Please send an e-mail to sales@devart.com to clarify this situation.

tim_vanhorn
Posts: 3
Joined: Tue 07 Oct 2008 16:23
Location: United States

Package Load Failure

Post by tim_vanhorn » Mon 20 Oct 2008 22:55

I receive a similar error when starting VS 2005 SP1 after installing Oradirect.Net Mobile Standard Edition, V4.75.43.1 on XP Professional SP2. The error I receive states:

Package Load Failure

Package 'CoreLab.Oracle.Vs.OracleDataProviderPackage' has failed to load properly ( GUID = {18F9FE6C-9800-FBE0-DF0A-29182AA775C3}). Please contact package vendor for assistance. Application restart is recommended, due to possible enviironment corruption.


This occurs when I open VS 2005 with a non-administrator account. Are there any special permissions needed at the OS level when this package loads?
:?:

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Wed 22 Oct 2008 16:24

To use our assemblies you need the access to GAC and to the ...\Program Files\Devart\OraDirect.NET2 Mobile folder.

Please clarify, does it mean that there are no any errors with administrator account?

tim_vanhorn
Posts: 3
Joined: Tue 07 Oct 2008 16:23
Location: United States

Error Corelab.Oracle.Vs.OracleDataProviderPackage VS2008

Post by tim_vanhorn » Fri 24 Oct 2008 19:03

Thanks for replying. Here is what I have checked so far...

When I start VS2005 from an account in the local Administrators group I receive no error.

I've checked and I have access to the GAC and the ..\Program Files\Devart\OraDirect.NET2 Mobile folder using my normal user account. When I check the GAC, I don't see any assemblies for OraDirect.Net, regardless of account. Should I see any assemblies?

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Tue 28 Oct 2008 17:12

Thank you for the bug report. We have reproduced the problem. We will investigate it and notify you about the results as soon as possible.

Shalex
Site Admin
Posts: 8248
Joined: Thu 14 Aug 2008 12:44

Post by Shalex » Thu 30 Oct 2008 10:08

The problem is fixed. Look forward to the next build of dotConnect for Oracle.

tim_vanhorn
Posts: 3
Joined: Tue 07 Oct 2008 16:23
Location: United States

Error Corelab.Oracle.Vs.OracleDataProviderPackage VS2008

Post by tim_vanhorn » Mon 24 Nov 2008 16:50

Now that dotConnect for Oracle Mobile 5 has been released, which you say has corrected the problem previously posted in this thread, how do I get this update? Using the link and login information emailed to me for previous updates I can only find OraDirect.Net Mobile 4.75.43 and not dotConnect for Oracle Mobile 5.

Thanks.

Devart
Site Admin
Posts: 3282
Joined: Tue 26 Oct 2004 13:51

Post by Devart » Tue 25 Nov 2008 11:55

Dear tim_vanhorn,

we sent you update information.

Regards, Devart Sales

Post Reply