It worked a few minutes ago...

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
Post Reply
Posts: 1
Joined: Tue 22 Jul 2008 12:11

It worked a few minutes ago...

Post by kibble » Tue 22 Jul 2008 12:19

Five days ago I installed 'Core Lab OraDirect Data Provider for .Net2 Trial' and ' Core Lab OraDeveloper Tools for Visual Studio 2008' and had it working nicely up to about 10 minutes ago.

I can still compile my project but when I visit the localhost development server and bring up the page in question I now recieve this error...


Server Error in '/' Application.

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The connection name 'OracleServices' was not found in the applications configuration or the connection string is empty.

Source Error:

Line 168: minRequiredNonalphanumericCharacters="1" passwordAttemptWindow="10"
Line 169: passwordStrengthRegularExpression="" />
Line 170: <add name="AspNetOracleMembershipProvider" type="CoreLab.Oracle.Web.Providers.OracleMembershipProvider, CoreLab.Oracle.Web, Version=, Culture=neutral, PublicKeyToken=09af7300eec23701"
Line 171: description="OraDirect membership provider" connectionStringName="OracleServices"
Line 172: enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true"

Source File: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\machine.config Line: 170

Version Information: Microsoft .NET Framework Version:2.0.50727.3031; ASP.NET Version:2.0.50727.3031


Any ideas why it would work 10 minutes ago and not now? I have made no changes to the code since. I run as a restricted user and can not change the machine.config without logging out and logging back in as an administrative user.
Many Thanks...

Devart Team
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Post by AndreyR » Thu 24 Jul 2008 09:15

Hello, Kibble.

Please try adding to your web.config file lines like the following:

Code: Select all


Replace "Your connection string" with the connection string pointing to your ASP.NET database.

Regards, Andrey.

Post Reply