Problems with connection

Discussion of open issues, suggestions and bugs regarding ADO.NET provider for Oracle
DmitryGm
Devart Team
Posts: 59
Joined: Fri 11 Dec 2020 10:27

Re: Problems with connection

Post by DmitryGm » Fri 02 Jul 2021 16:26

Please clarify the version of dotConnect for Oracle you use.
Note that according Revision history:

8.4.437 18-Jun-15 The IPv6 protocol is supported in the Direct mode
8.5.535 12-Nov-15 The bug with a connection via DNS name in the IPv6 network in the Direct mode is fixed

hansjoergp
Posts: 39
Joined: Wed 31 May 2017 14:33

Re: Problems with connection

Post by hansjoergp » Mon 12 Jul 2021 05:29

We use the 9.14.1228. Newer version we can't use because every version has bugs which we have already reported

DmitryGm
Devart Team
Posts: 59
Joined: Fri 11 Dec 2020 10:27

Re: Problems with connection

Post by DmitryGm » Tue 13 Jul 2021 16:14

The bug that you had reported was fixed in the dotConnect for Oracle 9.14.1228
viewtopic.php?t=44493

So you can use also the newest build: 9.14.1298
https://www.devart.com/dotconnect/oracle/download.html


We couldn't reproduce the issue described in this topic in our environment.
If I understood correctly, the following happens in your case:

OCI mode:
Host=fe80::900d:6ed2:637b:851%12; - works
Host=host.domain.local; - works

Direct mode:
Server=fe80::900d:6ed2:637b:851%12; - works
Server=host.domain.local; - doesn't work

Is it right?

I suppose the problem may be related to the configuration of your DNS.
Let's do a test like this:

1.) In the your local host file (C:\Windows\System32\drivers\etc\hosts) specify

Code: Select all

fe80::900d:6ed2:637b:851%12    oraip6
2.) In Direct mode specify "Server=oraip6;" in the connection string.

Does it work?

hansjoergp
Posts: 39
Joined: Wed 31 May 2017 14:33

Re: Problems with connection

Post by hansjoergp » Wed 14 Jul 2021 05:50

In the test program I have the newest version.
If I make your test I have the same situation
- ODP.Net works
- OCI Mode works
- Direct mode does not work. The error message changes:

Image

To get the connection string I use the following code:

Code: Select all

var oraCSB = new Devart.Data.Oracle.OracleConnectionStringBuilder() { Direct = directMode, UserId = "user", Password = "password" };
oraCSB.Server = "oraip6;
oraCSB.Sid = "sid";
oraCSB.Port = 1521;
oraCSB.LicenseKey = "licence"

hansjoergp
Posts: 39
Joined: Wed 31 May 2017 14:33

Re: Problems with connection

Post by hansjoergp » Wed 21 Jul 2021 13:25

Is there any news?

DmitryGm
Devart Team
Posts: 59
Joined: Fri 11 Dec 2020 10:27

Re: Problems with connection

Post by DmitryGm » Wed 21 Jul 2021 14:09

We still could not reproduce such behavior in our environment. 0x80004005 Network error may caused by some ipv6 network settings. The investigation is in progress.

hansjoergp
Posts: 39
Joined: Wed 31 May 2017 14:33

Re: Problems with connection

Post by hansjoergp » Wed 21 Jul 2021 14:12

If you need help and you have an test program with additional logging, I can launch it on the server and send you the log files

DmitryGm
Devart Team
Posts: 59
Joined: Fri 11 Dec 2020 10:27

Re: Problems with connection

Post by DmitryGm » Thu 22 Jul 2021 11:11

Please, let us know:
  • Do you use installed assemblies or NuGet packages?
  • Target Framework of your application.

hansjoergp
Posts: 39
Joined: Wed 31 May 2017 14:33

Re: Problems with connection

Post by hansjoergp » Thu 22 Jul 2021 11:34

- nuget packages
- .net 4.72

DmitryGm
Devart Team
Posts: 59
Joined: Fri 11 Dec 2020 10:27

Re: Problems with connection

Post by DmitryGm » Thu 22 Jul 2021 13:57

Thank you for your report. We have reproduced the issue in the conditions only:
  • NuGet packages
  • .NET Framework project
We shall inform you as soon as we fix the bug or have any further information.

DmitryGm
Devart Team
Posts: 59
Joined: Fri 11 Dec 2020 10:27

Re: Problems with connection

Post by DmitryGm » Tue 03 Aug 2021 11:22

Try the latest version of dotConnect for Oracle 9.14.1312
https://www.devart.com/dotconnect/oracle/download.html
(or update NuGet packages)

The bug with ipv6 in Direct mode was fixed.

Post Reply