Schema does not exist

Обсуждение возникших проблем, предложений и ошибок ODAC компонентов

Ответить
petrel
Сообщения: 48
Зарегистрирован: Вт 30 окт 2012 11:43

Schema does not exist

Сообщение petrel » Чт 12 окт 2017 12:33

Добрый день!
Версия ODAC 9.3.9 - XE5.

Стандартное(ODAC) окно соединения с СУБД - при нажатии кнопки "соединения" выскакивает (на некоторых машинах) сообщение "Schema does not exist" (причем как с драйвером так и direct).

При подтверждении "соединения" несколько раз вроде соединяется ... но запросы проходят с ошибками.

Если в TOraSession заполнить: сервер, пользователь, пароль ... и поставить ConnectPrompt = false соединение проходит нормально и программа работает.

ЧТО поменять в настройках ConnectDialog или настройках Windows или ... ?

MaximG
Devart Team
Сообщения: 91
Зарегистрирован: Пн 06 июл 2015 12:51

Re: Schema does not exist

Сообщение MaximG » Пн 23 окт 2017 08:33

Пожалуйста, попробуйте проверить работу своего приложения с использованием последней версии ODAC 10.1.3 . В случае, если описываемое поведение будет воспроизводится на этой версии ODAC, пожалуйста составьте и пришлите нам небольшой пример, при выполнении которого проблема проявляет себя. Это можно сделать с помощью формы e-support ( https://www.devart.com, меню "Support"\"Request Support")

petrel
Сообщения: 48
Зарегистрирован: Вт 30 окт 2012 11:43

Re: Schema does not exist

Сообщение petrel » Пт 03 ноя 2017 11:52

verion odac 10.1.3 - 'Schema does not exist'
вся информация забирается корректно из диалога и прописывается в реестр (где и нашлась устаревшая информация).
Эта ошибка пропала.

При этом в ConnectDialog не воспроизводятся на кириллице (перевод ввели в компоненте) при выполнении следующие свойства:
Schema, Connect Mode, Direct

MaximG
Devart Team
Сообщения: 91
Зарегистрирован: Пн 06 июл 2015 12:51

Re: Schema does not exist

Сообщение MaximG » Ср 08 ноя 2017 12:25

Спасибо за Вашу информацию. Мы реализуем перевод заголовков свойств Schema, Connect Mode, Direct в следующем билде ODAC

Ответить