BCD flag problems

BCD flag problems

Postby guduru_v » Sat 26 Feb 2005 00:06

Why don't coreLab DbExpresss dirvers comes with EnableBCD = False?

Because of this flag, now i have to maintian two codebases one for ORACLe, one for SQL SERVER.

I am using Borland Native SQLConneciton component, building my connection settings dynamically based on the databasetype (ORACLE, SQL SERVER),
then run my application.

Environment is D7, ORACLE 8i, SQLSERVER 2000 ; TSQLConnection which uses corelab drivename, getdriverfunction, libraryname and vendorlib values.

Because corelab dbexpress not accepting Integer fields in ORACLE as such, i had to convert them to BCD fields.


But at the same time, same code base is not working with SQL SERVER , because SQLSERVER expects integer type field as integer type only.


I am converting a large BDE app to DBexpress, it would be nice if corelab dbexpress comes with
enablebcd= flase by defualt and
Designconnection=true capability like in TDBXConnection of Dbexpress components.
guduru_v
 
Posts: 1
Joined: Fri 25 Feb 2005 23:57

Postby Paul » Tue 01 Mar 2005 09:36

DbxOda driver must be compatible with standard Borland dbExpress Oracle driver. EnableBCD = True emulates the default behavior of Borland dbExpress driver. Please see \Program Files\DbxOda\ReadMe.html file for information on how to use EnableBCD, SmallIntPrecision, IntegerPrecision, FloatPrecision, BCDPrecision options.
Paul
 
Posts: 725
Joined: Thu 28 Oct 2004 14:06


Return to dbExpress driver for Oracle