Could not parse the GetIndexes metadata command..

Could not parse the GetIndexes metadata command..

Postby martinw30 » Fri 15 Aug 2014 13:52

Following problem in our test enviroment:

Machine 1:
Running on Windows 2008 R2 -> Oracle 12c server this error occour:

Could not parse the GetIndexes metadata command. Problem near:- Original query: GetIndexes

Machine 2,3,4
Win 7 -> Oracle 12c
Working fine.

Machine 5
Running on Windows 2008 R2
Working fine.

All machines with dbexpoda.dll 6.23, have tested with 6.4.7 with same error. Project is build with Delphi XE2.
martinw30
 
Posts: 15
Joined: Fri 11 Jan 2013 13:46

Re: Could not parse the GetIndexes metadata command..

Postby AlexP » Mon 18 Aug 2014 10:45

Hello,

Please specify the action (server connection, opening DataSet etc.), during which the error occurs. Ensure, that all PCs use the same library version and the same actions are executed.
AlexP
Devart Team
 
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Could not parse the GetIndexes metadata command..

Postby martinw30 » Mon 18 Aug 2014 11:15

Same build (exe file), all pcs uses the same library version.

We can get a Oracle 11 working but Oracle 12 raises exception from a single computer. It executes from the same client folder from the same machine.

/Martin
martinw30
 
Posts: 15
Joined: Fri 11 Jan 2013 13:46

Re: Could not parse the GetIndexes metadata command..

Postby AlexP » Thu 21 Aug 2014 11:09

We can't reproduce the problem. Please try to reproduce it on a simple console application:

Code: Select all
begin
    SQLConnection.ConnectionName := 'Devart Oracle';
    SQLConnection.DriverName := 'DevartOracle';
    SQLConnection.LoginPrompt := False;
    SQLConnection.Params.Values['DataBase'] := 'DB';
    SQLConnection.Params.Values['User_Name'] := 'login';
    SQLConnection.Params.Values['Password'] := 'passwd';
    SQLConnection.Connected := True;
end;
AlexP
Devart Team
 
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Could not parse the GetIndexes metadata command..

Postby martinw30 » Mon 06 Oct 2014 08:13

Hello

If I use UseQuoteChar=True everthing works.

Agaist Oracle 11 UseQuoteChar=False works but against Oracle 12 we must set the parameter to true.

Both Oracle 11 and 12 works with UseQouteChar=True

Any more information why appreciated

Regards

/Martin
martinw30
 
Posts: 15
Joined: Fri 11 Jan 2013 13:46

Re: Could not parse the GetIndexes metadata command..

Postby AlexP » Tue 07 Oct 2014 08:55

Please send an application reproducing the problem to alexp*devart*com , and specify where the error occurs (connection to the server, opening the DataSet, etc.).
AlexP
Devart Team
 
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Could not parse the GetIndexes metadata command..

Postby martinw30 » Tue 07 Oct 2014 12:43

Sample project sent.
martinw30
 
Posts: 15
Joined: Fri 11 Jan 2013 13:46

Re: Could not parse the GetIndexes metadata command..

Postby AlexP » Wed 08 Oct 2014 10:27

I have received your email, however, the problem is not reproduced. Please specify the exact version of the Oracle client you are using.
AlexP
Devart Team
 
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Could not parse the GetIndexes metadata command..

Postby martinw30 » Wed 08 Oct 2014 10:42

Windows 7: Oracle 11.2.0.1.0
Windows 2008 R2: Oracle 12.1.0.1.0

/Martin
martinw30
 
Posts: 15
Joined: Fri 11 Jan 2013 13:46

Re: Could not parse the GetIndexes metadata command..

Postby AlexP » Thu 09 Oct 2014 09:40

We can't reproduce the problem. Please try using the Oracle client version 11 on "problem machines" and let us know the result.
AlexP
Devart Team
 
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Could not parse the GetIndexes metadata command..

Postby martinw30 » Thu 09 Oct 2014 09:42

We use Oracle client version 11 and reicievs the error.

Only way to get this work against Oracle 12 is to use UseQuoteChar=true
martinw30
 
Posts: 15
Joined: Fri 11 Jan 2013 13:46

Re: Could not parse the GetIndexes metadata command..

Postby AlexP » Fri 10 Oct 2014 12:31

Unfortunately, we can't reproduce the problem on our Oracle servers and computers. Try to experiment with different Oracle clients.
AlexP
Devart Team
 
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Could not parse the GetIndexes metadata command..

Postby martinw30 » Fri 10 Oct 2014 12:33

Tried with both 11 and 12 version same problem.

Will try to change Delphi version later.
martinw30
 
Posts: 15
Joined: Fri 11 Jan 2013 13:46

Re: Could not parse the GetIndexes metadata command..

Postby AlexP » Mon 13 Oct 2014 08:26

The problem may be due to the configuration of the Oracle clients. Please make sure that settings of the Oracle clients are the same (in the registry) on different machines.
AlexP
Devart Team
 
Posts: 5530
Joined: Tue 10 Aug 2010 11:35

Re: Could not parse the GetIndexes metadata command..

Postby martinw30 » Mon 13 Oct 2014 08:28

Any suggestion what I should look after? We have no Oracle client working against Oracle 12. Only UseQuoteChar=true works.
martinw30
 
Posts: 15
Joined: Fri 11 Jan 2013 13:46

Next

Return to dbExpress driver for Oracle