Enable BDC = False

Enable BDC = False

Postby ssantana » Mon 18 Aug 2008 19:44

Hi!!... Im with a problem when I use EnableBCD= False. In a stored procedure the parameter still as BCD Field. Why? The logic type will be Float Field
ssantana
 
Posts: 3
Joined: Mon 18 Aug 2008 19:37
Location: Brazil

Postby Plash » Tue 19 Aug 2008 11:32

Probably the parameters were created at design time and stored in the form. Try to recreate parameters. Clear the StoredProcName property, then set it again.
Plash
Devart Team
 
Posts: 2844
Joined: Wed 10 May 2006 07:09

Nothing!!

Postby ssantana » Tue 19 Aug 2008 15:22

I try this and nothing... it still be BCD field....!!!! this is a big problem because I need a 10 precision field.. and BCD only support 4.
ssantana
 
Posts: 3
Joined: Mon 18 Aug 2008 19:37
Location: Brazil

one more information

Postby ssantana » Tue 19 Aug 2008 18:37

its only occurs in stored procedure parameter....
ssantana
 
Posts: 3
Joined: Mon 18 Aug 2008 19:37
Location: Brazil

Postby Plash » Thu 21 Aug 2008 09:06

For all Delphi versions prior to Delphi 2007 you cannot set EnableBCD=False in the Params property of TSQLConnection. You should use TCRSQLConnection component instead.

If you are setting the StoredProcName property at desing time, the EnableBCD option also should be set at design time before setting the StoredProcName property. Check that you are using TCRSQLConnection component in this case.
Plash
Devart Team
 
Posts: 2844
Joined: Wed 10 May 2006 07:09


Return to dbExpress driver for Oracle