dbExpress driver 4.00 trial

dbExpress driver 4.00 trial

Postby vix » Thu 28 Jun 2007 14:42

Hi,

I've been trying to use the new dbExpress driver for Oracle in Delphi 2007. I downloaded and installed version 4.00 today, then I tried to run my application and I got an error message:

"Sorry, but your 30-day trial period has expired !
You may register DbxOda at http://crlab.com"

I bought the version 2.5 of this driver some months ago, and I'm considering an upgrade to a version compatible with Delphi 2007, but I'd like to test it first. What should I do to have the trial version correctly installed?

Thank you very much
vix
 
Posts: 2
Joined: Thu 28 Jun 2007 14:37

Postby Challenger » Mon 02 Jul 2007 11:54

If you are using Delphi 2007, please make sure that your application uses dbexpoda40.dll.
Challenger
Devart Team
 
Posts: 925
Joined: Thu 17 Nov 2005 10:53

Postby vix » Thu 26 Jul 2007 08:48

Sorry for my late reply, I've been on holiday for some weeks.

I have uninstall everything (including Delphi 2007) and installed it again. As a result, I got a different error message when trying to run my application with the trial version of DbxOda 4.00. The message is: Exception class TDBXError with message 'dbExpress Version 2.5 not supported yet'.

I guess that the problem is that my program is trying to use the wrong version of the driver, but how can I check this?

Thank you very much for your help
Last edited by vix on Thu 26 Jul 2007 08:49, edited 1 time in total.
vix
 
Posts: 2
Joined: Thu 28 Jun 2007 14:37

Postby Challenger » Thu 26 Jul 2007 12:11

Please make sure that the LibraryName property of the TSQLConnection component is "dbexpoda40.dll".
Challenger
Devart Team
 
Posts: 925
Joined: Thu 17 Nov 2005 10:53


Return to dbExpress driver for Oracle