Cannot open Table on my live server

Cannot open Table on my live server

Postby FlashHeart » Sun 20 Mar 2005 09:56

Hi,

This problem is driving me nuts. I'm developing an app on my dev machine that so far has only one form and that simply contains a TMyConnection and a TMyTable. The TMyConnection is set to connect to a MySQL server on our live server (a remote box) and the TMyTable is set to one of the live tables. The form has a single button opens the connection and the table. When I run this app on my dev box and click the button to open the table it opens fine and everything's ok (so the app is running on my dev box but opening a remote table), however when I copy this app to the remote server and run it there (so it's now attempting to open a table on the same machine as itself) then the app shows an error dialog message "'UK is not a valid floating point value". 'UK' is the value of the first column of the first row of the table. I can see that the connection was opened ok and that the error occurred while trying to open the table.

I just don't get this because the app had no problem opening the same table remotely, but when it runs on the server (so the app and table are on the same box) it trys to interperet a char value as a floating point value!

Can anyone help?? I'm out of ideas. I'm using Delphi5. My dev box is XP and our MySQL server box is 2000 Server. I'm not exactly sure what version of MyDAC I'm using - I bought the components 18 months ago and most of the files are dated 04-07-2003.

Thanks
FlashHeart
 
Posts: 5
Joined: Sat 22 Jan 2005 15:56

Postby FlashHeart » Sun 20 Mar 2005 13:11

I've fixed it! My 'Path' on the server had somehow gotten screwed and so the app was looking at the wrong libmysql.dll.
FlashHeart
 
Posts: 5
Joined: Sat 22 Jan 2005 15:56


Return to MySQL Data Access Components